【PAT甲级 - C++题解】1092 To Buy or Not to Buy

简介: 【PAT甲级 - C++题解】1092 To Buy or Not to Buy

1092 To Buy or Not to Buy


Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is Yes, please tell her the number of extra beads she has to buy; or if the answer is No, please tell her the number of beads missing from the string.


For the sake of simplicity, let’s use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.

655f66a53287415db40d6d93d258ff1e.jpg

Figure 1


Input Specification:

Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.


Output Specification:

For each test case, print your answer in one line. If the answer is Yes, then also output the number of extra beads Eva has to buy; or if the answer is No, then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.


Sample Input 1:

ppRYYGrrYBR2258
YrR8RrY

Sample Output 1:

Yes 8

Sample Input 2:

ppRYYGrrYB225
YrR8RrY

Sample Output 2:

No 2

题意

给定一个源串和一个目标串,判断目标串中的字符是否都能在源串中找到,如果都能找到则输出 Yes 并接着输出源串中多余的字符数量,否则输出 No 并接着输出目标串中缺少的字符数量。


思路

思路如下:


输入源串和目标串,并用哈希表来存储两个字符串中字符相差的数量,源串中的每个字符在哈希表中数量增加,而目标串中的每个字符在哈希表中数量减少。

计算给定字符串中多余字符以及缺少字符的数量,如果哈希表对应的字符数量是正数,则说明该字符在源串中是多余的;如果是负数,则说明该字符在源串中是缺少的。

如果缺少字符的数量大于 0 ,则输出 No 以及缺少字符数量;反之,输出 Yes 以及多余字符数量。

代码

#include<bits/stdc++.h>
using namespace std;
int main()
{
    //输入源串和目标串
    string a, b;
    cin >> a >> b;
    //统计源串和目标串的各颜色数量
    unordered_map<char, int> cnt;
    for (auto& s : a)  cnt[s]++;
    for (auto& p : b)  cnt[p]--;
    //计算多余或缺少的颜色数量
    int ns = 0, np = 0;
    for (auto& n : cnt)
    {
        if (n.second > 0)  ns += n.second;
        else np -= n.second;
    }
    //输出统计结果
    if (np)  cout << "No " << np << endl;
    else    cout << "Yes " << ns << endl;
    return 0;
}
目录
相关文章
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
65 0
|
算法 C++
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
82 0
|
C++
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
76 0
|
存储 C++ 容器
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
76 0
|
存储 C++
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
77 0
|
C++
【PAT甲级 - C++题解】1051 Pop Sequence
【PAT甲级 - C++题解】1051 Pop Sequence
77 0
|
人工智能 BI C++
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
132 0
|
23天前
|
存储 编译器 对象存储
【C++打怪之路Lv5】-- 类和对象(下)
【C++打怪之路Lv5】-- 类和对象(下)
22 4
|
23天前
|
编译器 C语言 C++
【C++打怪之路Lv4】-- 类和对象(中)
【C++打怪之路Lv4】-- 类和对象(中)
20 4
|
23天前
|
存储 安全 C++
【C++打怪之路Lv8】-- string类
【C++打怪之路Lv8】-- string类
18 1