【PAT甲级 - C++题解】1042 Shuffling Machine

简介: 【PAT甲级 - C++题解】1042 Shuffling Machine

1042 Shuffling Machine


Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid “inside jobs” where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.


The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the

following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where “S” stands for “Spade”, “H” for “Heart”, “C” for “Club”, “D” for “Diamond”, and “J” for “Joker”. A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.


Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.


Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.


Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14


Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3


题意

现有 54 张牌,初始顺序为:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2


现在给定一个洗牌顺序,需要将上述的顺序按给定顺序进行洗牌,例如当前卡牌顺序为 {S3,H5,C1,D13,J2} ,而洗牌顺序为 {4,2,5,3,1} ,则洗牌后的卡牌顺序为 {J2,H5,D13,S3,C1} ,如果再洗一次那么顺序为 {C1,H5,S3,J2,D13} 。


输入第一行为洗牌的次数 k ,后跟洗牌的顺序数组,输出洗牌 k 次后的卡牌顺序。


思路

思路如下:


1.用数组 p 来保存洗牌顺序,用数组 q 来保存洗牌后的结果,需要先初始化数组 q ,将 S1~J2 映射到 1~54 ,洗牌时用数字表示,输出时再映射回字母。

2.进行 k 次洗牌,用数组 w 进行备份,方便下一次洗牌使用。

3.输出洗牌后的结果,需要将数字再映射回字母。注意,行末不能有空格。


代码

#include<bits/stdc++.h>
using namespace std;
vector<int> p(55), q(55), w(55);
//输出映射后的卡牌
void print(int x)
{
    if (x <= 13)   cout << "S" << x;
    else if (x > 13 && x <= 26)    cout << "H" << x - 13;
    else if (x > 26 && x <= 39)    cout << "C" << x - 26;
    else if (x > 39 && x <= 52)    cout << "D" << x - 39;
    else    cout << 'J' << x - 52;
}
int main()
{
    int k;
    cin >> k;
    //输入打乱顺序
    for (int i = 1; i <= 54; i++)  cin >> p[i];
    //初始化卡牌顺序
    for (int i = 1; i <= 54; i++)  q[i] = i;
    //进行k次洗牌
    while (k--)
    {
        w = q;
        for (int i = 1; i <= 54; i++)  q[p[i]] = w[i];
    }
    //输出洗牌后的顺序
    for (int i = 1; i <= 54; i++)
    {
        print(q[i]);
        if (i != 54)   cout << " ";
    }
}
目录
相关文章
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
73 0
|
算法 C++
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
94 0
|
C++
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
86 0
|
存储 C++ 容器
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
82 0
|
存储 C++
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
84 0
|
C++
【PAT甲级 - C++题解】1051 Pop Sequence
【PAT甲级 - C++题解】1051 Pop Sequence
89 0
|
人工智能 BI C++
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
143 0
|
11天前
|
C++ 芯片
【C++面向对象——类与对象】Computer类(头歌实践教学平台习题)【合集】
声明一个简单的Computer类,含有数据成员芯片(cpu)、内存(ram)、光驱(cdrom)等等,以及两个公有成员函数run、stop。只能在类的内部访问。这是一种数据隐藏的机制,用于保护类的数据不被外部随意修改。根据提示,在右侧编辑器补充代码,平台会对你编写的代码进行测试。成员可以在派生类(继承该类的子类)中访问。成员,在类的外部不能直接访问。可以在类的外部直接访问。为了完成本关任务,你需要掌握。
52 18
|
11天前
|
存储 编译器 数据安全/隐私保护
【C++面向对象——类与对象】CPU类(头歌实践教学平台习题)【合集】
声明一个CPU类,包含等级(rank)、频率(frequency)、电压(voltage)等属性,以及两个公有成员函数run、stop。根据提示,在右侧编辑器补充代码,平台会对你编写的代码进行测试。​ 相关知识 类的声明和使用。 类的声明和对象的声明。 构造函数和析构函数的执行。 一、类的声明和使用 1.类的声明基础 在C++中,类是创建对象的蓝图。类的声明定义了类的成员,包括数据成员(变量)和成员函数(方法)。一个简单的类声明示例如下: classMyClass{ public: int
38 13
|
11天前
|
编译器 数据安全/隐私保护 C++
【C++面向对象——继承与派生】派生类的应用(头歌实践教学平台习题)【合集】
本实验旨在学习类的继承关系、不同继承方式下的访问控制及利用虚基类解决二义性问题。主要内容包括: 1. **类的继承关系基础概念**:介绍继承的定义及声明派生类的语法。 2. **不同继承方式下对基类成员的访问控制**:详细说明`public`、`private`和`protected`继承方式对基类成员的访问权限影响。 3. **利用虚基类解决二义性问题**:解释多继承中可能出现的二义性及其解决方案——虚基类。 实验任务要求从`people`类派生出`student`、`teacher`、`graduate`和`TA`类,添加特定属性并测试这些类的功能。最终通过创建教师和助教实例,验证代码
37 5