【PAT甲级 - C++题解】1155 Heap Paths

简介: 【PAT甲级 - C++题解】1155 Heap Paths

1155 Heap Paths


In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))


One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.


Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:


Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:


For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.


Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50
• 1
• 2

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap
• 1
• 2
• 3
• 4
• 5

Sample Input 3:

8
10 28 15 12 34 9 8 56


Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap


题意


在计算机科学中,堆是一种的基于树的专用数据结构,它具有堆属性:


如果 P 是 C 的父结点,则在大顶堆中 P 结点的权值大于或等于 C 结点的权值,在小顶堆中 P 结点的权值小于或等于 C 结点的权值。


一种堆的常见实现是二叉堆,它是由完全二叉树来实现的。


可以肯定的是,在大顶/小顶堆中,任何从根到叶子的路径都必须按非递增/非递减顺序排列。


你的任务是检查给定完全二叉树中的每个路径并输出它们,以判断它是否是堆

思路


我们可以通过递归的方式去输出路径,每查找到一条路径就输出它。

在输出路径的时候,去判断该序列是递增还是递减还是非顺序,用两个变量去记录,一个是 lt 表示该堆是小根堆即如果该序列是递增的就标记 lt = true ,另一个是 gt 表示该堆是大根堆即如果该序列是递减的就标记 gt = true 。

遍历完所有路径后,判断 lt 和 gt ,如果两个变量都是真值,说明该树不是堆(只有满足大根堆或小根堆性质的完全二叉树才能被称为堆),否则输出对应的判断结果。

代码

#include<bits/stdc++.h>
using namespace std;
const int N = 1010;
int n;
int h[N];
vector<int> path;
bool lt, gt;
void dfs(int u)
{
    path.push_back(h[u]);
    if (u * 2 > n)   //如果已经到达叶子结点
    {
        cout << path[0];
        for (int i = 1; i < path.size(); i++)
        {
            cout << " " << path[i];
            //判断该树是大根堆还是小根堆
            if (path[i] > path[i - 1])   lt = true;
            else if (path[i] < path[i - 1])  gt = true;
        }
        cout << endl;
    }
    //先递归右子树,再递归左子树
    if (u * 2 + 1 <= n)   dfs(u * 2 + 1);
    if (u * 2 <= n)   dfs(u * 2);
    path.pop_back();
}
int main()
{
    cin >> n;
    for (int i = 1; i <= n; i++)   cin >> h[i];
    dfs(1);
    if (gt && lt)  puts("Not Heap");
    else if (gt) puts("Max Heap");
    else    puts("Min Heap");
    return 0;
}


目录
相关文章
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
70 0
|
算法 C++
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
93 0
|
C++
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
84 0
|
存储 C++ 容器
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
79 0
|
存储 C++
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
82 0
|
C++
【PAT甲级 - C++题解】1051 Pop Sequence
【PAT甲级 - C++题解】1051 Pop Sequence
86 0
|
人工智能 BI C++
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
141 0
|
2月前
|
存储 编译器 C语言
【c++丨STL】string类的使用
本文介绍了C++中`string`类的基本概念及其主要接口。`string`类在C++标准库中扮演着重要角色,它提供了比C语言中字符串处理函数更丰富、安全和便捷的功能。文章详细讲解了`string`类的构造函数、赋值运算符、容量管理接口、元素访问及遍历方法、字符串修改操作、字符串运算接口、常量成员和非成员函数等内容。通过实例演示了如何使用这些接口进行字符串的创建、修改、查找和比较等操作,帮助读者更好地理解和掌握`string`类的应用。
63 2
|
2月前
|
存储 编译器 C++
【c++】类和对象(下)(取地址运算符重载、深究构造函数、类型转换、static修饰成员、友元、内部类、匿名对象)
本文介绍了C++中类和对象的高级特性,包括取地址运算符重载、构造函数的初始化列表、类型转换、static修饰成员、友元、内部类及匿名对象等内容。文章详细解释了每个概念的使用方法和注意事项,帮助读者深入了解C++面向对象编程的核心机制。
113 5
|
2月前
|
存储 编译器 C++
【c++】类和对象(中)(构造函数、析构函数、拷贝构造、赋值重载)
本文深入探讨了C++类的默认成员函数,包括构造函数、析构函数、拷贝构造函数和赋值重载。构造函数用于对象的初始化,析构函数用于对象销毁时的资源清理,拷贝构造函数用于对象的拷贝,赋值重载用于已存在对象的赋值。文章详细介绍了每个函数的特点、使用方法及注意事项,并提供了代码示例。这些默认成员函数确保了资源的正确管理和对象状态的维护。
112 4