【PAT甲级 - C++题解】1138 Postorder Traversal

简介: 【PAT甲级 - C++题解】1138 Postorder Traversal

1138 Postorder Traversal


Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:


For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.


Sample Input:

7
1 2 3 4 5 6 7
2 3 1 5 4 7 6
• 1
• 2
• 3

Sample Output:

3


题意


给定前序遍历和中序遍历的结果,构建二叉树。

要求输出该二叉树的后序遍历结果的第一个元素值。


思路


  1. 由于题目给定每个结点的值都不同,所以可以用哈希表存储每个结点在中序数组中的下标,方便后续使用。
  2. 通过下标构建二叉树(其中 k-il-1 表示左子树结点个数):



e7a37d75c98b4305a913d0fdebf59adf.png



  1. 因为构建二叉树的时候是先去递归左子树,所以第一个遍历到的结点就是二叉树最左边的那个点,而后序遍历结果的第一个点就是二叉树最左边的那个点,故只用在构建过程中记录一下即可。

代码

#include<bits/stdc++.h>
using namespace std;
const int N=50010;
int n;
int pre[N],in[N];
unordered_map<int,int> pos;
int post;
void build(int il,int ir,int pl,int pr)
{
    int root=pre[pl];
    int k=pos[root];
    if(il<k)    build(il,k-1,pl+1,pl+1+k-il-1);
    if(ir>k)    build(k+1,ir,pl+1+k-il-1+1,pr);
    if(!post)   post=root;
}
int main()
{
    cin>>n;
    for(int i=0;i<n;i++)    cin>>pre[i];    //输入前序数组
    for(int i=0;i<n;i++)    //输入中序数组,并记录每个元素的下标
    {
        cin>>in[i];
        pos[in[i]]=i;
    }
    build(0,n-1,0,n-1);
    cout<<post<<endl;
    return 0;
}


目录
相关文章
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
66 0
|
算法 C++
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
82 0
|
C++
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
77 0
|
存储 C++ 容器
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
76 0
|
存储 C++
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
79 0
|
C++
【PAT甲级 - C++题解】1051 Pop Sequence
【PAT甲级 - C++题解】1051 Pop Sequence
80 0
|
人工智能 BI C++
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
135 0
|
4天前
|
存储 编译器 C++
【c++】类和对象(下)(取地址运算符重载、深究构造函数、类型转换、static修饰成员、友元、内部类、匿名对象)
本文介绍了C++中类和对象的高级特性,包括取地址运算符重载、构造函数的初始化列表、类型转换、static修饰成员、友元、内部类及匿名对象等内容。文章详细解释了每个概念的使用方法和注意事项,帮助读者深入了解C++面向对象编程的核心机制。
24 5
|
11天前
|
存储 编译器 C++
【c++】类和对象(中)(构造函数、析构函数、拷贝构造、赋值重载)
本文深入探讨了C++类的默认成员函数,包括构造函数、析构函数、拷贝构造函数和赋值重载。构造函数用于对象的初始化,析构函数用于对象销毁时的资源清理,拷贝构造函数用于对象的拷贝,赋值重载用于已存在对象的赋值。文章详细介绍了每个函数的特点、使用方法及注意事项,并提供了代码示例。这些默认成员函数确保了资源的正确管理和对象状态的维护。
40 4
|
12天前
|
存储 编译器 Linux
【c++】类和对象(上)(类的定义格式、访问限定符、类域、类的实例化、对象的内存大小、this指针)
本文介绍了C++中的类和对象,包括类的概念、定义格式、访问限定符、类域、对象的创建及内存大小、以及this指针。通过示例代码详细解释了类的定义、成员函数和成员变量的作用,以及如何使用访问限定符控制成员的访问权限。此外,还讨论了对象的内存分配规则和this指针的使用场景,帮助读者深入理解面向对象编程的核心概念。
35 4