【PAT甲级 - C++题解】1086 Tree Traversals Again

简介: 【PAT甲级 - C++题解】1086 Tree Traversals Again

1086 Tree Traversals Again


An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.



633f7537caa044b3a498df5d46a90a34.jpg


Figure 1

Input Specification:


Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop


Sample Output:

3 4 2 6 5 1



题意


通过使用栈可以以非递归方式实现二叉树的中序遍历。


例如,假设遍历一个如下图所示的 6 66 节点的二叉树(节点编号从 1 11 到 6 66)。


则堆栈操作为:push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop() 。

320a13e4424543bea0cf12f2fab08f4c.jpg



我们可以从此操作序列中生成唯一的二叉树。

你的任务是给出这棵树的后序遍历。

思路


可以从用栈实现二叉树的中序遍历的思路中找到规律:


如果上一次操作是 Push ,则当前 Push 的结点是其父结点的左孩子,这里的父结点是上次 Push 的结点。例如,push(1); push(2); ,则结点 2 是上次 Push 的结点 1 的左孩子。

如果上一次操作是 Pop ,则当前 Push 的结点是其父结点的右孩子,这里的父节点是上次 Pop 的结点。例如,push(1); push(2); push(3); pop(); pop(); push(4); ,结点 4 是上次 Pop 的结点 2 的右孩子。

如果上一次没有操作,则当前 Push 的结点就是根结点。


代码

#include<bits/stdc++.h>
using namespace std;
const int N = 40;
int n;
int l[N], r[N]; //用哈希表来存储每个结点左孩子的下标
void dfs(int u, int root)
{
    if (!u)  return;
    dfs(l[u], root);
    dfs(r[u], root);
    cout << u;
    if (u != root) cout << " "; //最后一个结点输出末尾不能加空格
}
int main()
{
    int last = 0, type, root;
    stack<int> stk;
    cin >> n;
    for (int i = 0; i < n * 2; i++)
    {
        string op;
        cin >> op;
        if (op == "Push")
        {
            int x;
            cin >> x;
            if (!last)   root = x; //第一个结点为根结点
            else    //设置父结点的左右孩子
            {
                if (type == 0) l[last] = x;  //上个操作是Push
                else    r[last] = x;  //上个操作是Pop
            }
            last = x;
            type = 0; //表示Push
            stk.push(x);
        }
        else
        {
            last = stk.top();
            stk.pop();
            type = 1; //表示Pop
        }
    }
    dfs(root, root); //后序遍历
    return 0;
}


目录
相关文章
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
66 0
|
算法 C++
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
85 0
|
C++
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
77 0
|
存储 C++ 容器
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
76 0
|
存储 C++
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
79 0
|
3天前
|
存储 编译器 C语言
【c++丨STL】string类的使用
本文介绍了C++中`string`类的基本概念及其主要接口。`string`类在C++标准库中扮演着重要角色,它提供了比C语言中字符串处理函数更丰富、安全和便捷的功能。文章详细讲解了`string`类的构造函数、赋值运算符、容量管理接口、元素访问及遍历方法、字符串修改操作、字符串运算接口、常量成员和非成员函数等内容。通过实例演示了如何使用这些接口进行字符串的创建、修改、查找和比较等操作,帮助读者更好地理解和掌握`string`类的应用。
18 2
|
9天前
|
存储 编译器 C++
【c++】类和对象(下)(取地址运算符重载、深究构造函数、类型转换、static修饰成员、友元、内部类、匿名对象)
本文介绍了C++中类和对象的高级特性,包括取地址运算符重载、构造函数的初始化列表、类型转换、static修饰成员、友元、内部类及匿名对象等内容。文章详细解释了每个概念的使用方法和注意事项,帮助读者深入了解C++面向对象编程的核心机制。
36 5
|
15天前
|
存储 编译器 C++
【c++】类和对象(中)(构造函数、析构函数、拷贝构造、赋值重载)
本文深入探讨了C++类的默认成员函数,包括构造函数、析构函数、拷贝构造函数和赋值重载。构造函数用于对象的初始化,析构函数用于对象销毁时的资源清理,拷贝构造函数用于对象的拷贝,赋值重载用于已存在对象的赋值。文章详细介绍了每个函数的特点、使用方法及注意事项,并提供了代码示例。这些默认成员函数确保了资源的正确管理和对象状态的维护。
47 4
|
17天前
|
存储 编译器 Linux
【c++】类和对象(上)(类的定义格式、访问限定符、类域、类的实例化、对象的内存大小、this指针)
本文介绍了C++中的类和对象,包括类的概念、定义格式、访问限定符、类域、对象的创建及内存大小、以及this指针。通过示例代码详细解释了类的定义、成员函数和成员变量的作用,以及如何使用访问限定符控制成员的访问权限。此外,还讨论了对象的内存分配规则和this指针的使用场景,帮助读者深入理解面向对象编程的核心概念。
44 4
|
2月前
|
存储 编译器 对象存储
【C++打怪之路Lv5】-- 类和对象(下)
【C++打怪之路Lv5】-- 类和对象(下)
28 4