【PAT甲级 - C++题解】1043 Is It a Binary Search Tree

简介: 【PAT甲级 - C++题解】1043 Is It a Binary Search Tree

1043 Is It a Binary Search Tree


A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:


The left subtree of a node contains only nodes with keys less than the node’s key.

The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.

Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.


Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:


For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11
• 1
• 2

Sample Output 1:

YES
5 7 6 8 11 10 8



Sample Input 2:

7
8 10 11 8 6 7 5
• 1
• 2

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11
• 1
• 2

Sample Output 3:

NO


题意


二叉搜索树 (BST) 递归定义为具有以下属性的二叉树:


若它的左子树不空,则左子树上所有结点的值均小于它的根结点的值

若它的右子树不空,则右子树上所有结点的值均大于或等于它的根结点的值

它的左、右子树也分别为二叉搜索树

我们将二叉搜索树镜面翻转得到的树称为二叉搜索树的镜像。


现在,给定一个整数序列,请你判断它是否可能是某个二叉搜索树或其镜像进行前序遍历的结果。


如果是某个二叉搜索树或其镜像进行前序遍历的结果,则输出 YES ,并输出其后序遍历的结果,否则输出 NO 。

思路


先输入先序遍历的数组,然后可以通过该数组进行排序,就得到了中序遍历的数组,因为二叉搜索树的中序遍历数组是有序的。


然后分别去判断该树是否为二叉搜索树或者镜像二叉搜索树,判断方法和之前的一道题根据后序数组以及中序数组来构建二叉树思想很类似,这里是根据前序数组以及中序数组来判断是否为二叉搜索树或镜像二叉搜索树。我们只用搞定二叉搜索树的判断,镜像二叉搜索树的判断就出来了,只用将前面的操作进行一个逆向翻转即可。下面我给出正常二叉搜索树的判断图(其中 k-il-1 表示左子树结点个数):

c02adceb49e84d7287c313ef037ec3d7.png


  1. 如果满足要求,输出该树的后序遍历即可。

代码

#include<bits/stdc++.h>
using namespace std;
const int N = 1010;
int inorder[N], preorder[N], postorder[N];
int n, cnt;
bool build(int il, int ir, int pl, int pr, int type)
{
    if (il > ir)   return true;
    int root = preorder[pl];
    int k;
    if (!type)   //对二查搜索树的判断
    {
        for (k = il; k <= ir; k++) //找到该结点在中序序列中的位置
            if (root == inorder[k])
                break;
        if (k > ir)    return false;
    }
    else    //对镜像二叉搜索树的判断
    {
        for (k = ir; k >= il; k--)
            if (root == inorder[k])
                break;
        if (k < il)    return false;
    }
    //递归判断其左右子树是否满足要求
    int res = true;
    if (!build(il, k - 1, pl + 1, pl + 1 + (k - il - 1), type))  res = false;
    if (!build(k + 1, ir, pl + 1 + (k - il - 1) + 1, pr, type))  res = false;
    postorder[cnt++] = root;  //将根结点加入后序数组中
    return res;
}
int main()
{
    //输入结点信息
    cin >> n;
    for (int i = 0; i < n; i++)
    {
        cin >> preorder[i];
        inorder[i] = preorder[i];
    }
    sort(inorder, inorder + n);    //获得中序序列
    if (build(0, n - 1, 0, n - 1, 0))    //判断是否为二叉搜索树
    {
        puts("YES");
        cout << postorder[0];
        for (int i = 1; i < cnt; i++)  cout << " " << postorder[i];
        cout << endl;
    }
    else    //判断是否为镜像二叉搜索树
    {
        reverse(inorder, inorder + n);
        cnt = 0;
        if (build(0, n - 1, 0, n - 1, 1))
        {
            puts("YES");
            cout << postorder[0];
            for (int i = 1; i < cnt; i++)  cout << " " << postorder[i];
            cout << endl;
        }
        else    puts("NO");
    }
    return 0;
}


目录
相关文章
|
3月前
|
Java 程序员 C语言
IT圈茶余饭后的“鄙视链” C,C++,Java,Python
IT圈茶余饭后的“鄙视链” C,C++,Java,Python
81 0
|
10月前
|
算法 C++ iOS开发
软件开发入门教程网 Search之C++ 接口(抽象类)
软件开发入门教程网 Search之C++ 接口(抽象类)
|
10月前
|
数据安全/隐私保护 C++ iOS开发
软件开发入门教程网 Search之C++ 继承
软件开发入门教程网 Search之C++ 继承
|
10月前
|
并行计算 程序员 C++
软件开发入门教程网 Search之C++ 简介
软件开发入门教程网 Search之C++ 简介
|
1月前
|
编译器 开发工具 C++
【Python】已解决error: Microsoft Visual C++ 14.0 or greater is required. Get it with “Microsoft C++ Build
【Python】已解决error: Microsoft Visual C++ 14.0 or greater is required. Get it with “Microsoft C++ Build
301 0
|
3月前
|
缓存 算法 C语言
【C++ 标准查找算法 】C++标准库查找算法深入解析(In-depth Analysis of C++ Standard Library Search Algorithms)
【C++ 标准查找算法 】C++标准库查找算法深入解析(In-depth Analysis of C++ Standard Library Search Algorithms)
64 0
|
10月前
|
编译器 C语言 C++
软件开发入门教程网 Search之C++ 环境设置
软件开发入门教程网 Search之C++ 环境设置
|
3月前
|
算法 前端开发 大数据
【C/C++ 基础知识 】C++中易混淆的函数和关键字:std::find vs std::search,std::remove vs std::erase,remove vs delete
【C/C++ 基础知识 】C++中易混淆的函数和关键字:std::find vs std::search,std::remove vs std::erase,remove vs delete
56 0
|
10月前
|
存储 程序员 C语言
软件开发入门教程网 Search之C++ 动态内存
软件开发入门教程网 Search之C++ 动态内存
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
51 0