【PAT甲级 - C++题解】1021 Deepest Root

简介: 【PAT甲级 - C++题解】1021 Deepest Root

1021 Deepest Root


A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤104) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes’ numbers.

Output Specification:


For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5
• 1
• 2
• 3
• 4
• 5

Sample Output 1:

3
4
5


Sample Input 2:

5
1 3
1 4
2 5
3 4
• 1
• 2
• 3
• 4
• 5

Sample Output 2:

Error: 2 components


题意

第一行包含整数 N  ,表示节点数量。


节点编号为 1 ∼ N


接下来 N − 1  行,每行包含两个整数,表示两个节点之间存在一条边。


输出最深的根的节点编号。


如果最深的根不唯一,则按照从小到大的顺序,将它们依次输出,每个占一行。


如果给定的图不是树,输出 Error: K components ,其中 K KK 是图中连通分量的数量。


思路


在输入每条边的信息时,我们可以利用并查集来对该图进行判断,输入前令 k = n ,每输入一条边时就判断这条边两个端点是否已经在同一个连通块中,如果不在则将 k - 1 ,最终的 k 值就是该图连通块的数量。

如果 k > 1 则该图不是树,输出 Error: K components ,否则对每个结点都进行一次 dfs 操作,找到最深的结点。注意,我们这里的结点是从小到大进行 dfs ,所以最终得到的结果一定是单调递增的,不用再进行排序。

在 dfs 的过程中,注意不能回溯即当前结点再访问其父结点,需要额外进行判断。

代码

#include<bits/stdc++.h>
using namespace std;
const int N = 10010, M = 2 * N;
int h[N], e[M], ne[M], idx;
int p[N];
int n;
//链式前向星保存每一条边
void add(int a, int b)
{
    e[idx] = b, ne[idx] = h[a], h[a] = idx++;
}
//并查集查找操作
int find(int x)
{
    if (p[x] != x) p[x] = find(p[x]);
    return p[x];
}
//获取当前最大深度,其中u表示当前结点,father表示父结点
int dfs(int u, int father)
{
    int depth = 0;
    //遍历其所有孩子结点
    for (int i = h[u]; ~i; i = ne[i])
    {
        int j = e[i];
        if (j == father)   continue;   //防止回溯
        depth = max(depth, dfs(j, u) + 1);
    }
    return depth;
}
int main()
{
    //初始化
    cin >> n;
    memset(h, -1, sizeof h);
    for (int i = 1; i <= n; i++)   p[i] = i;
    //输入所有边,且用并查集判断该图是否为树
    int k = n;
    for (int i = 0; i < n - 1; i++)
    {
        int a, b;
        cin >> a >> b;
        add(a, b), add(b, a);
        if (find(a) != find(b))
        {
            k--;
            p[find(a)] = find(b);
        }
    }
    if (k > 1) printf("Error: %d components\n", k);
    else
    {
        vector<int> nodes;
        int max_depth = 0;
        for (int i = 1; i <= n; i++)
        {
            int depth = dfs(i, 0); //获得当前深度
            if (depth > max_depth) //如果当前深度大于当前最大深度
            {
                nodes.clear();
                max_depth = depth;
                nodes.push_back(i);
            }
            else if (depth == max_depth)   //如果当前深度等于当前最大深度
                nodes.push_back(i);
        }
        //输出结果
        for (auto& x : nodes)  cout << x << endl;
    }
    return 0;
}
目录
相关文章
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
66 0
|
算法 C++
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
85 0
|
C++
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
77 0
|
存储 C++ 容器
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
76 0
|
存储 C++
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
79 0
|
C++
【PAT甲级 - C++题解】1051 Pop Sequence
【PAT甲级 - C++题解】1051 Pop Sequence
81 0
|
3天前
|
存储 编译器 C语言
【c++丨STL】string类的使用
本文介绍了C++中`string`类的基本概念及其主要接口。`string`类在C++标准库中扮演着重要角色,它提供了比C语言中字符串处理函数更丰富、安全和便捷的功能。文章详细讲解了`string`类的构造函数、赋值运算符、容量管理接口、元素访问及遍历方法、字符串修改操作、字符串运算接口、常量成员和非成员函数等内容。通过实例演示了如何使用这些接口进行字符串的创建、修改、查找和比较等操作,帮助读者更好地理解和掌握`string`类的应用。
18 2
|
9天前
|
存储 编译器 C++
【c++】类和对象(下)(取地址运算符重载、深究构造函数、类型转换、static修饰成员、友元、内部类、匿名对象)
本文介绍了C++中类和对象的高级特性,包括取地址运算符重载、构造函数的初始化列表、类型转换、static修饰成员、友元、内部类及匿名对象等内容。文章详细解释了每个概念的使用方法和注意事项,帮助读者深入了解C++面向对象编程的核心机制。
36 5
|
15天前
|
存储 编译器 C++
【c++】类和对象(中)(构造函数、析构函数、拷贝构造、赋值重载)
本文深入探讨了C++类的默认成员函数,包括构造函数、析构函数、拷贝构造函数和赋值重载。构造函数用于对象的初始化,析构函数用于对象销毁时的资源清理,拷贝构造函数用于对象的拷贝,赋值重载用于已存在对象的赋值。文章详细介绍了每个函数的特点、使用方法及注意事项,并提供了代码示例。这些默认成员函数确保了资源的正确管理和对象状态的维护。
47 4
|
17天前
|
存储 编译器 Linux
【c++】类和对象(上)(类的定义格式、访问限定符、类域、类的实例化、对象的内存大小、this指针)
本文介绍了C++中的类和对象,包括类的概念、定义格式、访问限定符、类域、对象的创建及内存大小、以及this指针。通过示例代码详细解释了类的定义、成员函数和成员变量的作用,以及如何使用访问限定符控制成员的访问权限。此外,还讨论了对象的内存分配规则和this指针的使用场景,帮助读者深入理解面向对象编程的核心概念。
44 4