【PAT甲级 - C++题解】1058 A+B in Hogwarts

简介: 【PAT甲级 - C++题解】1058 A+B in Hogwarts

1058 A+B in Hogwarts

题目详情 - 1058 A+B in Hogwarts (pintia.cn)

中文翻译


If you are a fan of Harry Potter, you would know the world of magic has its own currency system – as Hagrid explained it to Harry, “Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it’s easy enough.” Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:


Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.


Output Specification:


For each test case you should output the sum of A and B in one line, with the same format as the input.



Sample Input:

3.2.1 10.16.27
• 1

Sample Output:

14.1.28


题意


这道题是要我们去模拟进制运算,给定两个数,格式是 a.b.c ,c 的范围在 [0,29) ,b 的范围在 [0,17) ,也就是说 c 每达到 29 就会往 b 进一位即二十九进制,而 b 每达到 17 就会往 a 进一位即十七进制。


现在就要我们通过这个进制要求去计算两个给定格式的数之和,并且输出最终结果。

思路


  1. 将两个数分别用 a,b,c 输入进来,然后先将对应位相加。
  2. 然后处理进位情况,由于进位是从后往前进,所以我们先要计算最后一位即 c 的进位情况,将 c 进的位加到 b 上,然后再处理 b 的进位情况并加到 a 上。
  3. 最后输出结果。

代码

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int a1, b1, c1, a2, b2, c2;
    scanf("%d.%d.%d %d.%d.%d", &a1, &b1, &c1, &a2, &b2, &c2);
    a1 += a2, b1 += b2, c1 += c2;
    b1 += c1 / 29, c1 %= 29;
    a1 += b1 / 17, b1 %= 17;
    printf("%d.%d.%d", a1, b1, c1);
    return 0;
}
目录
相关文章
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
70 0
|
算法 C++
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
93 0
|
C++
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
84 0
|
存储 C++ 容器
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
79 0
|
存储 C++
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
82 0
|
C++
【PAT甲级 - C++题解】1051 Pop Sequence
【PAT甲级 - C++题解】1051 Pop Sequence
86 0
|
人工智能 BI C++
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
141 0
|
2月前
|
存储 编译器 C语言
【c++丨STL】string类的使用
本文介绍了C++中`string`类的基本概念及其主要接口。`string`类在C++标准库中扮演着重要角色,它提供了比C语言中字符串处理函数更丰富、安全和便捷的功能。文章详细讲解了`string`类的构造函数、赋值运算符、容量管理接口、元素访问及遍历方法、字符串修改操作、字符串运算接口、常量成员和非成员函数等内容。通过实例演示了如何使用这些接口进行字符串的创建、修改、查找和比较等操作,帮助读者更好地理解和掌握`string`类的应用。
63 2
|
2月前
|
存储 编译器 C++
【c++】类和对象(下)(取地址运算符重载、深究构造函数、类型转换、static修饰成员、友元、内部类、匿名对象)
本文介绍了C++中类和对象的高级特性,包括取地址运算符重载、构造函数的初始化列表、类型转换、static修饰成员、友元、内部类及匿名对象等内容。文章详细解释了每个概念的使用方法和注意事项,帮助读者深入了解C++面向对象编程的核心机制。
113 5
|
2月前
|
存储 编译器 C++
【c++】类和对象(中)(构造函数、析构函数、拷贝构造、赋值重载)
本文深入探讨了C++类的默认成员函数,包括构造函数、析构函数、拷贝构造函数和赋值重载。构造函数用于对象的初始化,析构函数用于对象销毁时的资源清理,拷贝构造函数用于对象的拷贝,赋值重载用于已存在对象的赋值。文章详细介绍了每个函数的特点、使用方法及注意事项,并提供了代码示例。这些默认成员函数确保了资源的正确管理和对象状态的维护。
112 4