【PAT甲级 - C++题解】1016 Phone Bills

简介: 【PAT甲级 - C++题解】1016 Phone Bills

1016 Phone Bills


A long-distance telephone company charges its customers by the following rules:


Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.


Input Specification:


Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.


The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.


The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (MM:dd:HH:mm), and the word on-line or off-line.


For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:


For each test case, you must print a phone bill for each customer.


Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:HH:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

思路


我们可以用一个 m a p mapmap 来存储所有人的所有账单,m a p mapmap 会自动对人名进行排序,这样就满足字典序从小到大输出每个人的要求。

输入信息时,我们可以利用 s c a n f scanfscanf 函数的性质,按照规定格式进行输入。同时,我们可以利用 s p r i n t f sprintfsprintf 函数,再存储一份格式化时间,方便后续的打印操作。

记录账单时间时,我们可以将时间用分钟来表示,由于一组数据的所有时间都会在一个月内,所以最多会有 31 3131 天即 1440 × 31 1440×311440×31 分钟。这样转换,方便后续前缀和的计算。

可以用一个 s u m sumsum 数组来计算前缀和,用来存储一个月中每分钟所花费的钱,这样当计算一段区间时间时,直接用后面那段时间的 s u m [ b . m i n u t e ] sum[b.minute]sum[b.minute] 减去前面那段时间的 s u m [ a . m i n u t e ] sum[a.minute]sum[a.minute] 就是所花费的美元。注意,s u m sumsum 中已经将分钟转换成对应的美元,需要计算对应的时间以及除以 100 100100 将美分转换成美元。

在输出时,只用从小到大遍历 m a p mapmap 中的元素即可,由于每个人的账单的时间输入时可能是不按顺序的,所以需要先进行排序,然后从前往后进行配对,只有遇到相邻 o n _ l i n e on\_lineon_line 和 o f f _ l i n e off\_lineoff_line 时才算成功配对,否则其它的账单都要忽略。


代码

#include<bits/stdc++.h>
using namespace std;
const int M = 31 * 1440 + 10;
int cost[24];
double sum[M];
int n;
//存储每一个账单
struct Record {
    int minutes;  //计算该账单的时间
    string state; //记录该账单的状态
    string format_time; //记录标准时间,方便输出
    bool operator <(const Record& t)const {
        return minutes < t.minutes;
    }
};
map<string, vector<Record>> persons;  //存储每一个人的所有账单
int main()
{
    for (int i = 0; i < 24; i++)   cin >> cost[i];
    //计算前缀和,将一个月中的每分钟都预处理出来
    for (int i = 1; i < M; i++)   sum[i] = sum[i - 1] + cost[(i - 1) % 1440 / 60] / 100.0;
    //输入信息,将电话账单存入对应人物的map中
    cin >> n;
    char name[25], state[10], format_time[20];
    int month, day, hour, minute;
    for (int i = 0; i < n; i++)
    {
        scanf("%s %d:%d:%d:%d %s", name, &month, &day, &hour, &minute, state);
        sprintf(format_time, "%02d:%02d:%02d", day, hour, minute);
        int minutes = (day - 1) * 1440 + hour * 60 + minute;
        persons[name].push_back({ minutes,state,format_time });
    }
    for (auto person : persons)
    {
        auto name = person.first;
        auto records = person.second;
        sort(records.begin(), records.end());
        double total = 0;
        for (int i = 0; i + 1 < records.size(); i++)
        {
            auto a = records[i], b = records[i + 1];
            if (a.state == "on-line" && b.state == "off-line")
            {
                if (!total)  printf("%s %02d\n", name.c_str(), month);
                cout << a.format_time << " " << b.format_time;
                double c = sum[b.minutes] - sum[a.minutes];
                printf(" %d $%.2lf\n", b.minutes - a.minutes, c);
                total += c;
            }
        }
        if (total)   printf("Total amount: $%.2lf\n", total);
    }
    return 0;
}


目录
相关文章
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
66 0
|
算法 C++
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
83 0
|
C++
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
77 0
|
存储 C++ 容器
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
76 0
|
存储 C++
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
79 0
|
C++
【PAT甲级 - C++题解】1051 Pop Sequence
【PAT甲级 - C++题解】1051 Pop Sequence
80 0
|
人工智能 BI C++
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
137 0
|
1天前
|
存储 编译器 C语言
【c++丨STL】string类的使用
本文介绍了C++中`string`类的基本概念及其主要接口。`string`类在C++标准库中扮演着重要角色,它提供了比C语言中字符串处理函数更丰富、安全和便捷的功能。文章详细讲解了`string`类的构造函数、赋值运算符、容量管理接口、元素访问及遍历方法、字符串修改操作、字符串运算接口、常量成员和非成员函数等内容。通过实例演示了如何使用这些接口进行字符串的创建、修改、查找和比较等操作,帮助读者更好地理解和掌握`string`类的应用。
14 2
|
7天前
|
存储 编译器 C++
【c++】类和对象(下)(取地址运算符重载、深究构造函数、类型转换、static修饰成员、友元、内部类、匿名对象)
本文介绍了C++中类和对象的高级特性,包括取地址运算符重载、构造函数的初始化列表、类型转换、static修饰成员、友元、内部类及匿名对象等内容。文章详细解释了每个概念的使用方法和注意事项,帮助读者深入了解C++面向对象编程的核心机制。
33 5
|
14天前
|
存储 编译器 C++
【c++】类和对象(中)(构造函数、析构函数、拷贝构造、赋值重载)
本文深入探讨了C++类的默认成员函数,包括构造函数、析构函数、拷贝构造函数和赋值重载。构造函数用于对象的初始化,析构函数用于对象销毁时的资源清理,拷贝构造函数用于对象的拷贝,赋值重载用于已存在对象的赋值。文章详细介绍了每个函数的特点、使用方法及注意事项,并提供了代码示例。这些默认成员函数确保了资源的正确管理和对象状态的维护。
45 4