PTA 1050 String Subtraction (20 分)

简介: 代码如下

题目


Given two strings S 1 and S 2 , S=S 1 −S 2 is defined to be the remaining string after taking all the characters in S 2 from S 1 . Your task is simply to calculate S 1 −S 2 for any given strings. However, it might not be that simple to do it fast.


Input Specification: Each input file contains one test case. Each case consists of two lines which gives S 1 and S 2 , respectively. The string lengths of both strings are no more than 10 4 . It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.


Output Specification: For each test case, print S 1 −S 2 in one line.


Sample Input:
They are students.
aeiou
结尾无空行
Sample Output:
Thy r stdnts.
结尾无空行

解题思路

S1 = list(input())
S2 = list(input())
# S1 = list("They are students.")
# S2 = list("aeiou")
#暴力法
# for i in S2:
#     while True:
#         try:
#             S1.remove(i)
#         except:
#             break
# print("".join(S1))
#字典
S2Dict = dict()
for i in S2:
    S2Dict[i] = 1
res = ""
for j in S1:
    if j not in S2Dict:
        res += j
print(res)


目录
相关文章
|
C++
【PAT甲级 - C++题解】1050 String Subtraction
【PAT甲级 - C++题解】1050 String Subtraction
83 0
【1050】String Subtraction (20 分)
【1050】String Subtraction (20 分) 【1050】String Subtraction (20 分)
95 0
|
Python JavaScript
1050. String Subtraction (20)
分析:很无奈,我想用python。实在是简单呀。 python: s1 = raw_input() s2 = raw_input() for e in s2: if e in s1: s1 = s1.
776 0
|
3月前
|
Java 索引
java基础(13)String类
本文介绍了Java中String类的多种操作方法,包括字符串拼接、获取长度、去除空格、替换、截取、分割、比较和查找字符等。
40 0
java基础(13)String类
|
2月前
|
Java
【编程基础知识】(讲解+示例实战)方法参数的传递机制(值传递及地址传递)以及String类的对象的不可变性
本文深入探讨了Java中方法参数的传递机制,包括值传递和引用传递的区别,以及String类对象的不可变性。通过详细讲解和示例代码,帮助读者理解参数传递的内部原理,并掌握在实际编程中正确处理参数传递的方法。关键词:Java, 方法参数传递, 值传递, 引用传递, String不可变性。
58 1
【编程基础知识】(讲解+示例实战)方法参数的传递机制(值传递及地址传递)以及String类的对象的不可变性
|
2月前
|
安全 Java 测试技术
Java零基础-StringBuffer 类详解
【10月更文挑战第9天】Java零基础教学篇,手把手实践教学!
34 2
|
3月前
|
安全 Java
String类-知识回顾①
这篇文章回顾了Java中String类的相关知识点,包括`==`操作符和`equals()`方法的区别、String类对象的不可变性及其好处、String常量池的概念,以及String对象的加法操作。文章通过代码示例详细解释了这些概念,并探讨了使用String常量池时的一些行为。
String类-知识回顾①
|
2月前
|
存储 安全 C++
【C++打怪之路Lv8】-- string类
【C++打怪之路Lv8】-- string类
22 1
|
2月前
|
数据可视化 Java
让星星月亮告诉你,通过反射创建类的实例对象,并通过Unsafe theUnsafe来修改实例对象的私有的String类型的成员属性的值
本文介绍了如何使用 Unsafe 类通过反射机制修改对象的私有属性值。主要包括: 1. 获取 Unsafe 的 theUnsafe 属性:通过反射获取 Unsafe类的私有静态属性theUnsafe,并放开其访问权限,以便后续操作 2. 利用反射创建 User 类的实例对象:通过反射创建User类的实例对象,并定义预期值 3. 利用反射获取实例对象的name属性并修改:通过反射获取 User类实例对象的私有属性name,使用 Unsafe`的compareAndSwapObject方法直接在内存地址上修改属性值 核心代码展示了详细的步骤和逻辑,确保了对私有属性的修改不受 JVM 访问权限的限制
56 4
|
2月前
|
存储 安全 Java
【一步一步了解Java系列】:认识String类
【一步一步了解Java系列】:认识String类
25 2