题目
Given two strings S 1 and S 2 , S=S 1 −S 2 is defined to be the remaining string after taking all the characters in S 2 from S 1 . Your task is simply to calculate S 1 −S 2 for any given strings. However, it might not be that simple to do it fast.
Input Specification: Each input file contains one test case. Each case consists of two lines which gives S 1 and S 2 , respectively. The string lengths of both strings are no more than 10 4 . It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.
Output Specification: For each test case, print S 1 −S 2 in one line.
Sample Input: They are students. aeiou 结尾无空行 Sample Output: Thy r stdnts. 结尾无空行
解题思路
S1 = list(input()) S2 = list(input()) # S1 = list("They are students.") # S2 = list("aeiou") #暴力法 # for i in S2: # while True: # try: # S1.remove(i) # except: # break # print("".join(S1)) #字典 S2Dict = dict() for i in S2: S2Dict[i] = 1 res = "" for j in S1: if j not in S2Dict: res += j print(res)