题目
Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.
Input Specification: Each input file contains one test case. Each case is given in the following format:
N name[1] ID[1] grade[1] name[2] ID[2] grade[2] ... ... name[N] ID[N] grade[N] grade1 grade2 where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade's interval. It is guaranteed that all the grades are distinct.
Output Specification: For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student's name and ID, separated by one space. If there is no student's grade in that interval, output NONE instead.
Sample Input 1: 4 Tom CS000001 59 Joe Math990112 89 Mike CS991301 100 Mary EE990830 95 60 100 结尾无空行 Sample Output 1: Mike CS991301 Mary EE990830 Joe Math990112 结尾无空行 Sample Input 2: 2 Jean AA980920 60 Ann CS01 80 90 95 结尾无空行 Sample Output 2: NONE 结尾无空行
解题思路
N = int(input()) # N = int("4") inputList = [] for _ in range(N): name, ID, grade = map(str,input().split()) # name, ID, grade = map(str, "Joe Math990112 89".split()) inputList.append([name,ID,int(grade)]) grade1, grade2 = map(int,input().split()) # grade1, grade2 = map(int,"60 100".split()) resList = [] for each in inputList: if each[2]>= grade1 and each[2] <= grade2: resList.append(each) # 排序输出 resList.sort(key=lambda x:-x[2]) if len(resList) == 0: print("NONE") else: for each in resList: print(each[0],each[1])