【PAT甲级 - C++题解】1083 List Grades

简介: 【PAT甲级 - C++题解】1083 List Grades

1083 List Grades


Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.


Input Specification:

Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
... ...
name[N] ID[N] grade[N]
grade1 grade2

where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade’s interval. It is guaranteed that all the grades are distinct.


Output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student’s name and ID, separated by one space. If there is no student’s grade in that interval, output NONE instead.


Sample Input 1:

4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100

Sample Output 1:

Mike CS991301
Mary EE990830
Joe Math990112

Sample Output 1:

Mike CS991301
Mary EE990830
Joe Math990112

Sample Output 2:

NONE

题意

给定一个成绩范围 [g1,g2] ,要求找出在该成绩范围内的学生,并输出相应信息。


思路

思路如下:


定义学生结构体,存储学生信息,并重载比较运算符,排序时按照成绩降序排序。

输入学生的信息以及规定的成绩范围。

从前往后数组,将在成绩范围内的学生放到数组前面。

如果没有学生在成绩范围内,则输出 NONE ;反之,对在成绩范围内的学生按照成绩降序排序并输出其 name 和 id 。


代码

#include<bits/stdc++.h>
using namespace std;
const int N = 110;
int n;
//定义学生结构体
struct Person
{
    string name, id;
    int g;
    bool operator<(const Person& t)const
    {
        return g > t.g;
    }
}p[N];
int main()
{
    //输入学生信息
    cin >> n;
    for (int i = 0; i < n; i++)    cin >> p[i].name >> p[i].id >> p[i].g;
    //给定成绩范围
    int g1, g2;
    cin >> g1 >> g2;
    //将在给定成绩范围内的学生找出来
    int m = 0;
    for (int i = 0; i < n; i++)
        if (p[i].g >= g1 && p[i].g <= g2)
            p[m++] = p[i];
    //打印结果
    if (!m)  puts("NONE");
    else
    {
        //按照成绩降序排序
        sort(p, p + m);
        for (int i = 0; i < m; i++)
            cout << p[i].name << " " << p[i].id << endl;
    }
    return 0;
}
目录
相关文章
|
2天前
|
算法 C语言 C++
【c++丨STL】list的使用
本文介绍了STL容器`list`的使用方法及其主要功能。`list`是一种双向链表结构,适用于频繁的插入和删除操作。文章详细讲解了`list`的构造函数、析构函数、赋值重载、迭代器、容量接口、元素访问接口、增删查改操作以及一些特有的操作接口如`splice`、`remove_if`、`unique`、`merge`、`sort`和`reverse`。通过示例代码,读者可以更好地理解如何使用这些接口。最后,作者总结了`list`的特点和适用场景,并预告了后续关于`list`模拟实现的文章。
19 7
|
10天前
|
存储 编译器 C++
C++ initializer_list&&类型推导
在 C++ 中,`initializer_list` 提供了一种方便的方式来初始化容器和传递参数,而右值引用则是实现高效资源管理和移动语义的关键特性。尽管在实际应用中 `initializer_list&&` 并不常见,但理解其类型推导和使用方式有助于深入掌握现代 C++ 的高级特性。
16 4
|
2月前
|
存储 搜索推荐 C++
【C++篇】深度剖析C++ STL:玩转 list 容器,解锁高效编程的秘密武器2
【C++篇】深度剖析C++ STL:玩转 list 容器,解锁高效编程的秘密武器
56 2
【C++篇】深度剖析C++ STL:玩转 list 容器,解锁高效编程的秘密武器2
|
2月前
|
存储 算法 C++
【C++打怪之路Lv10】-- list
【C++打怪之路Lv10】-- list
22 1
|
2月前
|
存储 C++ 容器
【C++篇】深度剖析C++ STL:玩转 list 容器,解锁高效编程的秘密武器1
【C++篇】深度剖析C++ STL:玩转 list 容器,解锁高效编程的秘密武器
61 5
|
2月前
|
存储 编译器 C++
【C++篇】揭开 C++ STL list 容器的神秘面纱:从底层设计到高效应用的全景解析(附源码)
【C++篇】揭开 C++ STL list 容器的神秘面纱:从底层设计到高效应用的全景解析(附源码)
69 2
|
2月前
|
C++
【C++】C++ STL 探索:List使用与背后底层逻辑(三)
【C++】C++ STL 探索:List使用与背后底层逻辑
|
2月前
|
存储 缓存 C++
C++番外篇——list与vector的比较
C++番外篇——list与vector的比较
25 0
|
2月前
|
C++
C++番外篇——list的实现
C++番外篇——list的实现
21 0
|
2月前
|
存储 C++ 容器
C++入门9——list的使用
C++入门9——list的使用
21 0