题目
Look-and-say sequence is a sequence of integers as the following:
D, D1, D111, D113, D11231, D112213111, ... where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1's, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.
Input Specification: Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (≤ 40), separated by a space.
Output Specification: Print in a line the Nth number in a look-and-say sequence of D.
Sample Input: 1 8 结尾无空行 Sample Output: 1123123111 结尾无空行
解题思路
startInt, round = map(str, input().split()) # startInt, round = map(str, "1 8".split()) res = startInt # res = str(1231) for _ in range(int(round)-1): # resList = list(res) resList = res tempStr = None tempCount = 0 res = "" for val in resList: # for index,val in enumerate(resList): if val == tempStr: tempCount += 1 else:#如果不相等,就把上一个输出并新赋值 if tempStr != None: res += tempStr + str(tempCount) tempStr = val tempCount = 1 #处理最后一个符号 res += tempStr + str(tempCount) print(res)