HDU1002A + B Problem II

简介: HDU1002A + B Problem II

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211


Sample Output


Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110


解析:高精度

参考代码:

//HDU1002 高精度 
#include<iostream>
#include<string>
#include<string.h> 
using namespace std;
string a,b,c,d;
void solve(){
  int res[1005];
  int i ,j,k,r;
  i = j = k = r = 0;
  bool flag = false;
  memset(res,0,sizeof(res));
  cin>>a>>b;
  c = a;
  d = b;
  if(a.size()<b.size()||(a.size()==b.size()&&a<b)){//把把大数放前面. 
    swap(a,b);
  }
  for(i = a.size()-1,j = b.size() - 1; j>=0;i--,j--){
    res[k++] = (r+a[i]-'0'+b[j]-'0') % 10;
    r = (r+a[i]-'0'+b[j]-'0') / 10;//记录进位 
  }
  while(i>=0){//再把大数的其他部分进行运算 
    res[k++] = (r+a[i]-'0') % 10;
    r = (r+a[i]-'0') / 10;
    i--;
  } 
  if(r){
    res[k++] = r;//如果还有进位,进到最高位 
  }
  cout<<c<<" "<<"+"<<" "<<d<<" "<<"="<<" ";
  for(i = k  - 1; i >=0;i--){
    if(res[i]||flag){
      printf("%d",res[i]);
      flag = true;
    }
  }
  if(!flag){
    cout<<0;
  }
  cout<<endl;
}
int main()
{
  int cas;
  cin>>cas;
  for(int i = 0;i < cas;i++){
    if(i){
      cout<<endl;
    }
    printf("Case %d:\n",i+1);
    solve();
  }
  return 0;
} 
###############################################
#include<iostream>
#include<algorithm> 
#include<string.h>
using namespace std;
int main()
{
  char a[1005],b[1005];
  int i,j,n,s1[1005],s2[1005],len1,len2,len,cnt,res[1005];
  bool flag;
  scanf("%d",&n);
  for(cnt = 0;cnt < n;cnt++){
    if(cnt){
      cout<<endl;
    }
    flag = false;
    memset(s1,0,1005*sizeof(int));
    memset(s2,0,1005*sizeof(int));
    memset(res,0,1005*sizeof(int));
    memset(a,'0',sizeof(a));
    memset(b,'0',sizeof(b));
    scanf("%s",a);
    scanf("%s",b);
    len1 = strlen(a);
    len2 = strlen(b);
    len = max(len1,len2);
    //cout<<len<<endl; 
    j = 0;
    for(i = len1 - 1; i >=0;i--){
      s1[j++] = a[i]- '0' ;//倒叙存到 s1中 
    }
    j = 0;
    for(i = len2 - 1;i>=0;i--){
      s2[j++] = b[i]- '0';
    } 
    for(i = 0;i < len;i++){
      res[i] += s1[i]+s2[i];
      if(res[i]>=10){
        res[i+1]++;
        res[i] %= 10;
      }
//      s1[i]+=s2[i];
//      if(s1[i]>=10){
//        s1[i]-=10;
//        s1[i+1]++;
//      }
    } 
    printf("Case %d:\n",cnt+1);
    printf("%s + %s = ",a,b);
    for(i = 1005;i>=0;i--){
      if(res[i]!=0||flag){
        cout<<res[i];
        flag = true;
      }
    } 
    if(!flag){
      cout<<0;
    }
    cout<<endl;
  } 
 } 
相关文章
UVa1531 - Problem Bee
UVa1531 - Problem Bee
49 0
|
数据挖掘
HDU-1032,The 3n + 1 problem(水题)
HDU-1032,The 3n + 1 problem(水题)
HDU-1002,A + B Problem II(Java大数)
HDU-1002,A + B Problem II(Java大数)
HDU-1017,A Mathematical Curiosity
HDU-1017,A Mathematical Curiosity
|
物联网 Go C++
洛谷【2】P1001 A+B Problem
洛谷【2】P1001 A+B Problem
|
数据挖掘
HDOJ 1032(POJ 1207) The 3n + 1 problem
HDOJ 1032(POJ 1207) The 3n + 1 problem
128 0
|
机器学习/深度学习 自然语言处理