R7-7 cm2inch

简介: R7-7 cm2inch

Given foot and inch, the meter is (foot+inch/12)×0.3048.


What sould be the feet and inches for an input centimetre?


PS:One foot is 12 inches.


Input Format:

One integer in terms of cm.


Output Format:

One integer for the feet and another integer for the inches.


Sample Input:

170


Sample Output:

5 6


题解: 这个可以看成一个实数,可以看成两部分组成,整数部分由英尺组成,小数部分由英寸组成,我们要的是整数,所以n/30.48直接取整,小数部分带入公式即可

import java.util.Scanner;
public class Main {
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        int n = in.nextInt();
        int foot = (int)(n / 30.48);
        int inch = (int)((n / 30.48 - foot) * 12);
        System.out.println(foot + " " + inch);
    }
}
目录
相关文章
|
1月前
|
监控 数据可视化 项目管理
CM模式是什么?如何应用?
CM 模式(Construction Management)即建设管理模式,起源于20世纪60年代的美国,通过专业的建设管理团队在项目早期介入,优化设计方案,协调各方资源,有效提升项目质量和进度控制。该模式已广泛应用于各类建筑工程,并不断创新发展,适应数字化、绿色建筑及国际化需求。未来,CM模式将继续推动建筑行业的进步。
09Echarts - 折线图(Large scale area chart)
09Echarts - 折线图(Large scale area chart)
69 0
210Echarts - 数据区域缩放(Large scale area chart)
210Echarts - 数据区域缩放(Large scale area chart)
110 0
33Echarts - 柱状图(Large Scale Bar Chart)
33Echarts - 柱状图(Large Scale Bar Chart)
52 0
ALSTOM B5EC HENF105077R1 Normal thyristors
ALSTOM B5EC HENF105077R1 Normal thyristors
65 0
ALSTOM B5EC HENF105077R1 Normal thyristors
对 matplotlib.cm.RdYlBu() 的理解
对 matplotlib.cm.RdYlBu() 的理解
对 matplotlib.cm.RdYlBu() 的理解
|
存储
单位换算】存储单位(bit Byte KB MB GB TB PB EB ZB YB BB)时间单位(ms μs ns ps)长度单位(dm cm mm μm nm pm fm am zm ym)
单位换算】存储单位(bit Byte KB MB GB TB PB EB ZB YB BB)时间单位(ms μs ns ps)长度单位(dm cm mm μm nm pm fm am zm ym)
594 0