《Android应用开发与系统改造实战》——1.2节Android开发系统环境要求-阿里云开发者社区

开发者社区> 开发与运维> 正文

《Android应用开发与系统改造实战》——1.2节Android开发系统环境要求

简介:

本节书摘来自异步社区《Android应用开发与系统改造实战》一书中的第1章,第1.2节Android开发系统环境要求,作者 王保卫 , 申波,更多章节内容可以访问云栖社区“异步社区”公众号查看

1.2 Android开发系统环境要求
Android应用开发与系统改造实战

1.2.1 操作系统配置
在你的计算机上具备以下其中的一个条件方能正常地开发Android程序。

Windows XP(32-bit)、Windows Vista(32- or 64-bit)或Windows 7(32- or 64-bit)。
Mac OS X 10.5.8或later(x86 only)。
Linux(Ubuntu Linux,Lucid Lynx)。GNU C 库(glibc)2.11或者最新的。Ubuntu Linux、Lucid Lynx新版本。
1.2.2 开发环境配置要求
(1)Eclipse工具。

Eclipse 3.4(Ganymede)或者更新版本。
Eclipse JDT

插件(包含在大多数的Eclipse IDE包中)。

如果你想安装或者更新Eclipse,可以从下面的网址中下载:http://www.eclipse.org/downloads/
JDK 5 or JDK 6(仅安装JRE是不够的)。

Android Development Tools plugin(ADT)。

不适宜用GNU编译器来编译Java。

Apache Ant

1.8或者最新版本。 (2)注意。

如果JDK已经安装好了,请确信它是满足上面所列的系统要求。特别要注意的是,在Linux的某些版本的系统中,使用的是JDK1.4或者GNU编译器来编译Java,这两种都不能支持Android开发环境。

版权声明:本文首发在云栖社区,遵循云栖社区版权声明:本文内容由互联网用户自发贡献,版权归用户作者所有,云栖社区不为本文内容承担相关法律责任。云栖社区已升级为阿里云开发者社区。如果您发现本文中有涉嫌抄袭的内容,欢迎发送邮件至:developer2020@service.aliyun.com 进行举报,并提供相关证据,一经查实,阿里云开发者社区将协助删除涉嫌侵权内容。

分享:
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

其他文章