HDOJ 2019 数列有序!

简介: HDOJ 2019 数列有序!

Problem Description

有n(n<=100)个整数,已经按照从小到大顺序排列好,现在另外给一个整数x,请将该数插入到序列中,并使新的序列仍然有序。


Input

输入数据包含多个测试实例,每组数据由两行组成,第一行是n和m,第二行是已经有序的n个数的数列。n和m同时为0标示输入数据的结束,本行不做处理。


Output

对于每个测试实例,输出插入新的元素后的数列。


Sample Input

3 3

1 2 4

0 0


Sample Output

1 2 3 4

import java.util.Scanner;
class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            int n = sc.nextInt();
            int m = sc.nextInt();
            if(n==0){
                return ; 
            }
            int a[]=new int[n+1];
            int flag=1;
            for(int i=1;i<=n;i++){
                a[i]=sc.nextInt();
                if(a[i]<m){
                    a[i-1]=a[i];
                }else if(flag==1&&a[i]>=m){
                    a[i-1]=m;
                    flag=0;
                }
                if(i==n&&a[n]<m){
                    a[n]=m;
                }
            }
            System.out.print(a[0]);
            for(int i=1;i<=n;i++){
                System.out.print(" "+a[i]);
            }
            System.out.println();
        }
    }
}
目录
相关文章
HDOJ 2050 折线分割平面
HDOJ 2050 折线分割平面
134 0
HDOJ 2050 折线分割平面
HDOJ 1412 {A} + {B}
HDOJ 1412 {A} + {B}
117 0
|
机器学习/深度学习
HDOJ 2074 叠筐
HDOJ 2074 叠筐
118 0
HDOJ 1303 Doubles(简单题)
HDOJ 1303 Doubles(简单题)
101 0
HDOJ 1323 Perfection(简单题)
Problem Description From the article Number Theory in the 1994 Microsoft Encarta: “If a, b, c are integers such that a = bc, a is called a...
847 0
HDOJ 2802 F(N)
Problem Description Giving the N, can you tell me the answer of F(N)? Input Each test case contains a single integer N(1
718 0
HDOJ 2050 折线分割平面
Problem Description 我们看到过很多直线分割平面的题目,今天的这个题目稍微有些变化,我们要求的是n条折线分割平面的最大数目。比如,一条折线可以将平面分成两部分,两条折线最多可以将平面分成7部分,具体如下所示。
995 0
|
人工智能
HDOJ 2019 数列有序!
Problem Description 有n(n
821 0