HDOJ 2019 数列有序!

简介: Problem Description 有n(n

Problem Description
有n(n<=100)个整数,已经按照从小到大顺序排列好,现在另外给一个整数x,请将该数插入到序列中,并使新的序列仍然有序。

Input
输入数据包含多个测试实例,每组数据由两行组成,第一行是n和m,第二行是已经有序的n个数的数列。n和m同时为0标示输入数据的结束,本行不做处理。

Output
对于每个测试实例,输出插入新的元素后的数列。

Sample Input
3 3
1 2 4
0 0

Sample Output
1 2 3 4

import java.util.Scanner;

class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            int n = sc.nextInt();
            int m = sc.nextInt();
            if(n==0){
                return ; 
            }
            int a[]=new int[n+1];
            int flag=1;
            for(int i=1;i<=n;i++){
                a[i]=sc.nextInt();
                if(a[i]<m){
                    a[i-1]=a[i];
                }else if(flag==1&&a[i]>=m){
                    a[i-1]=m;
                    flag=0;
                }
                if(i==n&&a[n]<m){
                    a[n]=m;
                }
            }
            System.out.print(a[0]);
            for(int i=1;i<=n;i++){
                System.out.print(" "+a[i]);
            }
            System.out.println();

        }
    }
}
目录
相关文章
hdoj 1907
这是一道博弈的题,准确说是尼姆博弈,只要判断各项的异或值即可。
35 0
hdoj 2089 不要62
这题数据量相对比较小,可以暴力打表解决。不过我这里用数位dp 刚开始学数位dp,参考了别人的代码。
55 0
hdoj 4572 Bottles Arrangement
虽然不知道怎么做,但是AC还是没有问题的。 大概就是循环n次,从m加到m-n/2 除了最后一个数,每个都加两次。
39 0
|
机器学习/深度学习
HDOJ 2074 叠筐
HDOJ 2074 叠筐
118 0
HDOJ 2057 A + B Again
HDOJ 2057 A + B Again
107 0
|
Java BI 数据安全/隐私保护
HDOJ 2100 Lovekey
Problem Description XYZ-26进制数是一个每位都是大写字母的数字。 A、B、C、…、X、Y、Z 分别依次代表一个0 ~ 25 的数字,一个 n 位的26进制数转化成是10进制的规则如下 A0A1A2A3…An-1 的每一位代表的数字为a0a1a2a3…...
745 0
HDOJ 2056 Rectangles
Problem Description Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles.
1005 0
HDOJ 2050 折线分割平面
Problem Description 我们看到过很多直线分割平面的题目,今天的这个题目稍微有些变化,我们要求的是n条折线分割平面的最大数目。比如,一条折线可以将平面分成两部分,两条折线最多可以将平面分成7部分,具体如下所示。
995 0