2019 CCPC网络选拔赛题

简介: 2019 CCPC网络选拔赛题

1006题目:Shuffle Card

A deck of card consists of n cards. Each card is different, numbered from 1 to n. At first, the cards were ordered from 1 to n. We complete the shuffle process in the following way, In each operation, we will draw a card and put it in the position of the first card, and repeat this operation for m times.

Please output the order of cards after m operations.

Input

The first line of input contains two positive integers n and m.(1<=n,m<=105)

The second line of the input file has n Numbers, a sequence of 1 through n.

Next there are m rows, each of which has a positive integer si, representing the card number extracted by the i-th operation.

Output

Please output the order of cards after m operations. (There should be one space after each number.)Sample Input

5 3
1 2 3 4 5
3
4
3

Sample Output

3 4 1 2 5

解题思路:

这个题正常去写的话会时间超限,就是每一次输入m中的数,前面的数就要整体后移,这样就会时间超限,所以这个题就是把n、m的数分别存入a[]、b[]两个数组中,然后再定义一个book[]数组,每一次输出之后就把数标记一下。

注意:这个题没有换行,不是多实例,而且每个数字后面都有一个空格

程序代码:

#include<stdio.h>
#include<string.h>
int a[100010],b[100100],book[200000];
int main()
{
  int i,j,n,m,k;
  memset(book,0,sizeof(book));//数组初始话为0
  scanf("%d%d",&n,&m);
  for(i=1;i<=n;i++)
    scanf("%d",&a[i]);//把n个数存入数组中
  for(i=m;i>=1;i--)
    scanf("%d",&b[i]);//把m个数存入数组中
  for(i=1;i<=m;i++)
  {
    if(book[b[i]]==0)//把b[]数组中的数输出并标记
    {
      printf("%d ",b[i]);
      book[b[i]]=1;
    }
  }
  for(i=1;i<=n;i++)
  {
    if(book[a[i]]==0)
    {
      printf("%d ",a[i]);//把a[]数组中的数输出并标记
      book[a[i]]=1;
    }
  }
  return 0;
}

1007题目:Windows Of CCPC

Problem Description

In recent years, CCPC has developed rapidly and gained a large number of competitors .One contestant designed a design called CCPC Windows .The 1-st order CCPC window is shown in the figure:

And the 2-nd order CCPC window is shown in the figure:

We can easily find that the window of CCPC of order k is generated by taking the window of CCPC of order k−1 as C of order k, and the result of inverting C/P in the window of CCPC of order k−1 as P of order k.

And now I have an order k ,please output k-order CCPC Windows , The CCPC window of order k is a 2k∗2k matrix.

Input

The input file contains T test samples.(1<=T<=10)

The first line of input file is an integer T.

Then the T lines contains a positive integers k , (1≤k≤10)

Output

For each test case,you should output the answer .

Sample Input

3
1
2
3


Sample Output

CC
PC
CCCC
PCPC
PPCC
CPPC
CCCCCCCC
PCPCPCPC
PPCCPPCC
CPPCCPPC
PPPPCCCC
CPCPPCPC
CCPPPPCC
PCCPCPPC

解题思路:

这个题有点找规律的迹象,就是先把前两排输入,然后从第三排开始,看第二排是P还是C,如果是C,就记录为CCPC,如果是P,就记录PPCP。

程序代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
char e[2000][2000];
int main()
{
  int i,j,k,n,m,t;
  int T;
  scanf("%d",&T);
  while(T--)
  {
    scanf("%d",&n);
    m=pow(2,n);
    for(i=1;i<=m;i++)
      e[1][i]='C';
    for(i=1;i<=m;i++)
    {
      if(i%2==0)
        e[2][i]='C';
      else
        e[2][i]='P';
    }
    t=2;
    for(i=3;i<=m;i=i+2)
    {
      k=1;
      for(j=1;j<=m;j=j+2)
      {
        if(e[t][k]=='C')
        {
          e[i][j]='C';
          e[i][j+1]='C';
          e[i+1][j]='P';
          e[i+1][j+1]='C';
          k++;
        }
        else
        {
          e[i][j]='P';
          e[i][j+1]='P';
          e[i+1][j]='C';
          e[i+1][j+1]='P';
          k++;
        }
      }
      t++;
    }
    for(i=1;i<=m;i++)
    {
      for(j=1;j<=m;j++)
        printf("%c",e[i][j]);
      printf("\n");
    } 
  }
  return 0;
}
相关文章
广东工业大学第十四届程序设计竞赛 1004免费送气球(线段树)
广东工业大学第十四届程序设计竞赛 1004免费送气球(线段树)
86 0
2021 年高教社杯全国大学生数学建模竞赛题目(B 题 乙醇偶合制备 C4 烯烃)
C4 烯烃广泛应用于化工产品及医药的生产,乙醇是生产制备 C4 烯烃的原料。在制备过程中,催化剂组合(即:Co 负载量、Co/SiO2 和 HAP 装料比、乙醇浓度的组合)与温度对 C4 烯烃的选择性和 C4 烯烃收率将产生影响(名词解释见附录)。
450 0
2021 年高教社杯全国大学生数学建模竞赛题目(B 题 乙醇偶合制备 C4 烯烃)
|
存储 机器学习/深度学习 算法
【蓝桥杯集训·每日一题】AcWing 4074. 铁路与公路
文章目录 一、题目 1、原题链接 2、题目描述 二、解题报告 1、思路分析 2、时间复杂度 3、代码详解 三、知识风暴 Floyd 算法 Spfa 算法
118 0
|
C++
2020 第十一届蓝桥杯大赛软件赛省赛(第二场),C/C++大学B组题解
2020 第十一届蓝桥杯大赛软件赛省赛(第二场),C/C++大学B组题解
126 0
2020 第十一届蓝桥杯大赛软件赛省赛(第二场),C/C++大学B组题解
|
编译器 C语言 C++
试题 历届真题 交换瓶子【第七届】【省赛】【B组】
有N个瓶子,编号 1 ~ N,放在架子上。   比如有5个瓶子:   2 1 3 5 4   要求每次拿起2个瓶子,交换它们的位置。   经过若干次后,使得瓶子的序号为:   1 2 3 4 5   对于这么简单的情况,显然,至少需要交换2次就可以复位。   如果瓶子更多呢?你可以通过编程来解决。
172 0
试题 历届真题 交换瓶子【第七届】【省赛】【B组】
|
数据安全/隐私保护
经典骗局 - 9张卡一年多入账3000多万,男子被判帮助信息网络犯罪活动罪
经典骗局 - 9张卡一年多入账3000多万,男子被判帮助信息网络犯罪活动罪
178 0
经典骗局 - 9张卡一年多入账3000多万,男子被判帮助信息网络犯罪活动罪
|
Java 测试技术
选拔赛-杀伤力
有一个游戏,提供你两种资源MIN和GAS. 然后可以购买ZE,ST,SE三种设备武装你的军队.每单位ZE需要花费100 MIN ,但不需要GAS.每单位ST需要花费125 MIN和 50 GAS.每单位SE需要花费50 MIN和 100 GAS. 给定资源量和每种设备的杀伤值,求如何装备军队使得杀伤力最大
|
安全
美军正式成立网络战司令部 保护美军网络
  美国军方本周二宣布,正式成立新“网络战司令部”,进行数字战争,防护针对美军计算机网络的安全威胁。   美国国防部发言人布莱恩·惠特曼(Bryan Whitman)表示,美国国防部长罗伯特·盖茨(Robert Gates)已经正式建立了该司令部,归美国战略司令部(US Strategic Command)领导。
1447 0
《非洲归来 不必远方》读后感
 已经记不得从哪里看到这本书了,之所以会买这本书是被这本书中描写黑人肤色的段子给吸引了,想必大家应该都质疑过“非洲人真的黑到天黑人不见吗”的问题,如果你想解开心中的疑惑,那么推荐你买这本书,因为作者的文字的确非常幽默,阅读起来非常轻松,还记得我提过的《反脆弱》这本书么,如果从阅读的喜感来说简直一个是天一个是地,到底哪个是天哪个是地我想不用说大家也会明白。
1270 0

热门文章

最新文章

下一篇
开通oss服务