require-extension-hooks-babel
[![NPM Version](https://img.shields.io/npm/v/require-extension-hooks-babel.svg)](https://www.npmjs.com/package/require-extension-hooks-babel) ![GitHub release](https://img.shields.io/github/release/jackmellis/require-extension-hooks-babel.svg) ![npm downl
Last updated a year ago by jackmellis .
ISC · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install require-extension-hooks-babel 
SYNC missed versions from official npm registry.

NPM Version GitHub release npm downloads

require-extension-hooks-babel

Simple parser for vue files

Using require-extension-hooks you can transpile ES6/7/.. code to run in node. Although node supports 99.999% of ES6 features there is one major omission: export/import syntax.

Installation

npm install require-extension-hooks require-extension-hooks-babel --save-dev

Usage

const hooks = require('require-extension-hooks');
hooks('js').plugin('babel', {}).push();

// elsewhere...
import {foo} from './foo';

The second argument allows you to configure which options are passed into babel's transform function. By default this contains a node : current configuration to only use babel polyfills that node doesn't have.

Current Tags

  • 1.0.0-beta.1                                ...           beta (2 years ago)
  • 1.0.0                                ...           latest (a year ago)

4 Versions

  • 1.0.0                                ...           a year ago
  • 1.0.0-beta.1                                ...           2 years ago
  • 0.1.1                                ...           3 years ago
  • 0.1.0                                ...           4 years ago
Maintainers (1)
Downloads
Today 1
This Week 45
This Month 1
Last Day 9
Last Week 110
Last Month 501
Dependencies (2)
Dev Dependencies (0)
None

Copyright 2014 - 2016 © taobao.org |