ramda-fantasy
Fantasy Land compatible types for easy integration with Ramda
Last updated 3 years ago by scott-christopher .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install ramda-fantasy 
SYNC missed versions from official npm registry.

ramda-fantasy

Fantasy Land compatible types for easy integration with Ramda.

Project status

This project is in alpha status. The implementation of the Fantasy Land spec should be mostly stable. Any methods outside of the Fantasy Land spec are subject to change. The types also have not undergone thorough testing/use yet.

Available types

Name Setoid Semigroup Functor Applicative Monad Foldable ChainRec
Either ✔︎ ✔︎ ✔︎ ✔︎ ✔︎
Future ✔︎ ✔︎ ✔︎ ✔︎
Identity ✔︎ ✔︎ ✔︎ ✔︎ ✔︎
IO ✔︎ ✔︎ ✔︎ ✔︎
Maybe ✔︎ ✔︎ ✔︎ ✔︎ ✔︎ ✔︎ ✔︎
Reader ✔︎ ✔︎ ✔︎
Tuple ✔︎ ✔︎ ✔︎
State ✔︎ ✔︎ ✔︎ ✔︎

Access like so:

  var Either = require('ramda-fantasy').Either;

available translations

Spanish

Current Tags

  • 0.8.0                                ...           latest (3 years ago)

10 Versions

  • 0.8.0                                ...           3 years ago
  • 0.7.0                                ...           4 years ago
  • 0.6.1                                ...           4 years ago
  • 0.6.0                                ...           4 years ago
  • 0.5.0                                ...           4 years ago
  • 0.4.1                                ...           5 years ago
  • 0.4.0                                ...           5 years ago
  • 0.3.0                                ...           5 years ago
  • 0.2.0                                ...           5 years ago
  • 0.1.0                                ...           6 years ago
Downloads
Today 1
This Week 5
This Month 30
Last Day 1
Last Week 12
Last Month 24
Dependencies (1)
Dev Dependencies (9)
Dependents (108)

Copyright 2014 - 2017 © taobao.org |