postcss-slashcss
PostCSS plugin to remove duplicate css between multiple files
Last updated 2 years ago by gatsbill .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install postcss-slashcss 
SYNC missed versions from official npm registry.

postcss-slash-css

A PostCSS plugin that removes duplicates css properties and selector accross multiples css files.

Installation

npm install postcss-slash-css

Usage

const postcss = require("postcss");
const slashCSS = require("");

postcss([slashCSS({ targets: "**/*.css" })]);

See PostCSS docs for examples for your environment.

Options

targets

  • Type: string (glob using fast-glob)
  • Required

CSS files to search duplicates within source file.

Testing

To test this plugin, just run :

npm test

Example

You can see multiples exemples in the example folder, including gulp one.

License

This software is released under the terms of the MIT license.

Current Tags

  • 1.0.0                                ...           latest (2 years ago)

1 Versions

  • 1.0.0                                ...           2 years ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 1
Dependencies (2)
Dev Dependencies (1)
Dependents (0)
None

Copyright 2014 - 2016 © taobao.org |