is-async-supported
Check if async/await is available
Last updated 4 years ago by timneutkens .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install is-async-supported 
SYNC missed versions from official npm registry.

is-async-supported

Check if async/await is available

Installation

npm install is-async-supported

Usage

const isAsyncSupported = require('is-async-supported')

if(!isAsyncSupported()) {
  // Load runtime transform
}

Background

This package gives you the ability to load for example async-to-gen only when your Node.js environment doesn't support async/await.

At the moment this is not suitable for checking in browsers since it depends on the VM module provided by Node.js

Current Tags

  • 1.2.0                                ...           latest (4 years ago)

3 Versions

  • 1.2.0                                ...           4 years ago
  • 1.0.1                                ...           4 years ago
  • 1.0.0                                ...           4 years ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 312
Last Day 14
Last Week 96
Last Month 151
Dependencies (0)
None
Dev Dependencies (2)

Copyright 2014 - 2017 © taobao.org |