gulp-scope-css
A plugin for Gulp
Last updated 6 years ago by nixonchris .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install gulp-scope-css 
SYNC missed versions from official npm registry.

gulp-scope-css

NPM version Build Status Coverage Status Dependency Status

Gulp plugin to scope your CSS selectors with an additional level

Why?!?!

Adding additional depth to selectors should usually be avoided. In rare circumstances (such as building CSS as part of a reusable library) it's sometimes helpful to be able to add scope to all of your selectors so that your styles can be confined to certain sections of the page.

Usage

First, install gulp-scope-css as a development dependency:

npm install --save-dev gulp-scope-css

Then, add it to your gulpfile.js:

var scopeCss = require("gulp-scope-css");

gulp.src("./src/*.css")
    .pipe(scopeCss('.scope'))
    .pipe(gulp.dest("./dist"));

License

MIT License

Current Tags

  • 0.0.2                                ...           latest (6 years ago)

2 Versions

  • 0.0.2                                ...           6 years ago
  • 0.0.1                                ...           6 years ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 0
Dependencies (3)
Dev Dependencies (5)
Dependents (1)

Copyright 2014 - 2016 © taobao.org |