eslint-config-egoist
My personal eslint config.
Last updated 4 years ago by rem .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install eslint-config-egoist 
SYNC missed versions from official npm registry.

My personal ESLint config:

Type Extends
Default (optional ES2015+) egoist
Browser egoist/browser
Enforce ES2015+ egoist/esnext
Enforce ES2015+ in Browser only egoist/exnext-browser

Install

$ npm install -D eslint eslint-config-egoist

Usage

{
  // egoist | egoist/browser | egoist/esnext | egoist/esnext-browser
  "extends": "egoist"
}

You may also like eslint-config-egoist-vue for linting Vue projects.

Current Tags

  • 1.0.5                                ...           latest (4 years ago)

14 Versions

  • 1.0.5                                ...           4 years ago
  • 1.0.4                                ...           4 years ago
  • 1.0.3                                ...           4 years ago
  • 1.0.2                                ...           4 years ago
  • 1.0.1                                ...           4 years ago
  • 1.0.0                                ...           4 years ago
  • 0.0.8                                ...           4 years ago
  • 0.0.7                                ...           4 years ago
  • 0.0.6                                ...           4 years ago
  • 0.0.5                                ...           4 years ago
  • 0.0.4                                ...           4 years ago
  • 0.0.3                                ...           4 years ago
  • 0.0.2                                ...           5 years ago
  • 0.0.1                                ...           5 years ago
Maintainers (2)
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 0
Dependencies (1)
Dev Dependencies (0)
None

Copyright 2014 - 2016 © taobao.org |