eslint-config-airbnb-lite
ESlint config from airbnb rules, but without react ones.
Last updated 5 years ago by txchen .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install eslint-config-airbnb-lite 
SYNC missed versions from official npm registry.

This is Deprecated.

As of eslint-config-airbnb v0.0.8, it starts to support config set without react:

{
  "extends": "airbnb/base",
}

So this package is no longer needed.

eslint-config-airbnb-lite

This package provides Airbnb's .eslintrc as an extensible shared config, but without react rules.

Why

I like airbnb's javascript styleguide and eslint. Since eslint does not have presets included, we need to use 3rd party packages.

eslint-config-airbnb is a good one, but I don't need the react rules. This package removes the react related rules.

This package is still using babel-eslint, because eslint's native parser cannot support ES7 features well.

Usage

  1. npm install eslint-config-airbnb-lite babel-eslint --save-dev
  2. add "extends": "eslint-config-airbnb-lite" to your .eslintrc
  3. Override rules in .eslintrc

For example:

{
  "extends": "eslint-config-airbnb-lite",
  "rules" : {
    "semi": [2, "never"],
  }
}

See Airbnb's Javascript styleguide and the ESlint config docs for more information.

Current Tags

  • 1.0.4                                ...           latest (5 years ago)

5 Versions

  • 1.0.4                                ...           5 years ago
  • 1.0.3                                ...           5 years ago
  • 1.0.2                                ...           5 years ago
  • 1.0.1                                ...           5 years ago
  • 1.0.0                                ...           5 years ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 2
Last Day 0
Last Week 1
Last Month 5
Dependencies (1)
Dev Dependencies (0)
None

Copyright 2014 - 2017 © taobao.org |