brave-ecdsa
A wrapper around the ecdsa package and its dependencies
Last updated 6 years ago by damongant .
MIT · Original npm · Tarball · package.json
$ cnpm install brave-ecdsa 
SYNC missed versions from official npm registry.

A wrapper around the ecdsa package and its dependencies.

var ElCurDSA = require('brave-ecdsa');
var sha256 = require('sha256')

var elcur = new ElCurDSA()
var pair = {}
pair.privKey = elcur.genPrivateKey();
pair.pubKey = elcur.getPublicKey(pair.privKey);
var sig = elcur.sign(sha256("World"), pair.privKey)
var valid = elcur.verify(sha256("World"), sig, pair.pubKey)
console.dir(valid)

Current Tags

  • 0.0.3                                ...           latest (6 years ago)

2 Versions

  • 0.0.3                                ...           6 years ago
  • 0.0.2                                ...           6 years ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 0
Dependencies (5)
Dev Dependencies (0)
None
Dependents (0)
None

Copyright 2014 - 2017 © taobao.org |