开发者社区> 镜像站> NPM> @nuxtjs/eslint-config-typescript
@nuxtjs/eslint-config-typescript
Nuxt.js eslint typescript config
Last updated 10 months ago by clarkdo .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install @nuxtjs/eslint-config-typescript 
SYNC missed versions from official npm registry.

Nuxt ESLint Config

GitHub Actions npm (scoped with tag) npm

ESlint config used for Nuxt.js.

Usage

Do you want to add the config to your own projects? There you go:

  1. Add this package to your devDependencies
$ npm i -D @nuxtjs/eslint-config
# or
$ yarn add -D @nuxtjs/eslint-config
  1. Install eslint if not already present locally or globally
$ npm i -D eslint
# or
$ yarn add -D eslint
  1. Create a .eslintrc file

  2. Extend our config (you can use just the scope name as ESLint will assume the eslint-config prefix):

{
  "extends": [
    "@nuxtjs"
  ]
}

Full example

A full example .eslintrc for a project with babel support:

Dont forget to npm i -D babel-eslint or yarn add -D babel-eslint

{
  "root": true,
  "parserOptions": {
    "parser": "babel-eslint",
    "sourceType": "module"
  },
  "extends": [
    "@nuxtjs"
  ]
}

TypeScript

If you're using TypeScript, follow Usage section by replacing @nuxtjs/eslint-config by @nuxtjs/eslint-config-typescript.

And in your .eslintrc all you need is :

{
  "extends": [
    "@nuxtjs/eslint-config-typescript"
  ]
}

You can then edit/override same rules as you could with @nuxtjs/eslint-config but also TypeScript rules. You can find the list of supported TypeScript rules here.

Also see Nuxt TypeScript Support.

Migration guide from v0.x.y to v1.x.y

  1. Install the new peer dependencies (yarn add -D eslint-plugin-unicorn or npm i -D eslint-plugin-unicorn)
  2. Fix issues brought up due to new rules or disable them if needed

License

Setup inspired by eslint-config-standard

MIT - Nuxt.js team

Current Tags

  • 5.0.0                                ...           latest (21 days ago)

10 Versions

  • 5.0.0                                ...           21 days ago
  • 4.0.0                                ...           a month ago
  • 3.0.0                                ...           4 months ago
  • 2.1.0 [deprecated]           ...           4 months ago
  • 2.0.0                                ...           7 months ago
  • 1.0.2                                ...           10 months ago
  • 1.0.1                                ...           10 months ago
  • 1.0.0                                ...           a year ago
  • 0.1.3                                ...           a year ago
  • 0.1.2                                ...           a year ago