@microcode/flywaydb-cli
Install latest flywaydb-cli as a node module
Last updated a year ago by jsvennevid .
Apache-2.0 · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install @microcode/flywaydb-cli 
SYNC missed versions from official npm registry.

flywaydb-cli

A simple script installer for flywaydb cli

Usage Examples

"scripts": {
  "migrate": "flyway -X -configFile=conf/flyway.conf migrate"
}
"scripts": {
  "migrate": "flyway -X -user=postgres -schemas=public,another migrate"
}

Motivation

After looking into a couple other packages and having issues with JS wrappers. I decided to simply install flyway command-line tools from source and make it usage in npm.

Installation

npm i -S flywaydb-cli

CMD Reference

This simple installs the latest flyway command-line tools from source. All the auguments that flyway allows are available.

Tests

TODO

Contributors

Maintainer/Publisher sgraham785

Thank you to:

markgardner for the inspiration node-flywaydb

LiranBri for the updated source installer

License

Apache-2

Current Tags

  • 0.5.3-5.2.4                                ...           latest (a year ago)

3 Versions

  • 0.5.3-5.2.4                                ...           a year ago
  • 0.5.3                                ...           a year ago
  • 0.5.2                                ...           a year ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 0
Dependencies (7)
Dev Dependencies (8)
Dependents (0)
None

Copyright 2014 - 2017 © taobao.org |