@megalo/cli-plugin-flx-es6-to-es5
解决小程序开发工具勾选es6转es5报错的问题
Last updated a year ago by xsasadasdasdasd .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install @megalo/cli-plugin-flx-es6-to-es5 
SYNC missed versions from official npm registry.

@megalo/cli-plugin-flx-es6-to-es5

解决小程序开发工具勾选es6转es5报错的问题

解决思路:

  • fock regenerator-runtime 仓库,注释掉编译报错代码,发布新包 fock-regenerator-runtime
  • 通过 webpackalias 设置 将 regenerator-runtime 替换成 fock-regenerator-runtime

缺点:官方更新,这里也要更新,同步版本号

注意: 此插件只适用于 @megalo/cli beta及其以上版本创建的项目(@megalo/cli-service beta及其以上版本)

使用方式:

npm i @megalo/cli-plugin-flx-es6-to-es5 -D

安装后 @megalo/cli-service 会自动加载该插件

Current Tags

  • 1.0.0-beta.2                                ...           latest (a year ago)

2 Versions

  • 1.0.0-beta.2                                ...           a year ago
  • 1.0.0-beta.1                                ...           a year ago
Downloads
Today 0
This Week 0
This Month 2
Last Day 0
Last Week 1
Last Month 2
Dependencies (1)
Dev Dependencies (0)
None
Dependents (0)
None

Copyright 2014 - 2016 © taobao.org |