开发者社区> 问答> 正文

tomcat 8在用 jdk1.8 时 运行会报下面的错误

大家帮忙看看 是不是由于tomcat8不支持jdk1.8的问题啊 谢谢 大家

caused by: org.springframework.core.NestedIOException: ASM ClassReader failed to parse class file - probably due to a new Java class file version that isn't supported yet: file [/Users/eleme/Documents/ele.me/workspace/.metadata/.plugins/org.eclipse.wst.server.core/tmp1/wtpwebapps/coffee-eve-svr/WEB-INF/classes/me/ele/coffee/eve/webapi/base/AuthController.class]; nested exception is java.lang.IllegalArgumentException
    at org.springframework.core.type.classreading.SimpleMetadataReader.<init>(SimpleMetadataReader.java:56)
    at org.springframework.core.type.classreading.SimpleMetadataReaderFactory.getMetadataReader(SimpleMetadataReaderFactory.java:80)
    at org.springframework.core.type.classreading.CachingMetadataReaderFactory.getMetadataReader(CachingMetadataReaderFactory.java:102)
    at org.springframework.context.annotation.ClassPathScanningCandidateComponentProvider

展开
收起
小旋风柴进 2016-03-04 10:15:07 2953 0
1 条回答
写回答
取消 提交回答
  • 你应该用的是spring3吧,spring3跟jdk8有asm冲突,建议升级spring4或者使用jdk7就可以了

    2019-07-17 18:51:53
    赞同 展开评论 打赏
问答排行榜
最热
最新

相关电子书

更多
Apache Tomcat 的云原生演进 立即下载
CentOS Nginx PHP JAVA 多语言镜像使用手 立即下载
低代码开发师(初级)实战教程 立即下载