开发者社区 > 大数据与机器学习 > 实时计算 Flink > 正文

Flink1.17如果要用java8,是不是只能自己编译?

Flink1.17如果要用java8,是不是只能自己编译?

展开
收起
真的很搞笑 2024-03-11 13:55:24 59 0
2 条回答
写回答
取消 提交回答
  • 支持java8啊 ,此回答整理自钉群“【①群】Apache Flink China社区”

    2024-03-11 15:07:35
    赞同 展开评论 打赏
  • 面对过去,不要迷离;面对未来,不必彷徨;活在今天,你只要把自己完全展示给别人看。

    是的,如果需要在Flink 1.17中使用Java 8,通常需要自行编译源代码

    这是因为Flink 1.17默认支持的是Java 11,官方不再提供针对Java 8的预编译版本。具体步骤如下:

    1. 获取源码包:您可以从Flink官方网站或者GitHub上下载Flink的源码包。
    2. 准备编译环境:确保安装了JDK 1.8.0、Maven 3.2.5以及Git 2.27.0等必要的软件。在Windows环境下编译时可能还需要安装Node.js。
    3. 配置仓库路径:为了顺利编译,您可能需要配置Maven的settings.xml文件,添加镜像仓库地址以加速下载依赖。
    4. 编译打包命令:使用mvn clean package -DskipTests -Dfast命令进行编译打包。其中,-DskipTests用于跳过测试,-Dfast用于跳过QAplugins、JavaDocs等过程。
    5. 本地启动:编译完成后,可以使用IDEA或其他工具本地启动Flink环境,以便测试和调试。

    需要注意的是,自行编译可能会遇到各种依赖和环境配置问题,因此需要有一定的技术背景。如果您对Flink进行二次开发或为开源社区贡献代码,还需要了解如何配置CheckStyle来保证代码符合规范。

    2024-03-11 14:40:52
    赞同 展开评论 打赏

实时计算Flink版是阿里云提供的全托管Serverless Flink云服务,基于 Apache Flink 构建的企业级、高性能实时大数据处理系统。提供全托管版 Flink 集群和引擎,提高作业开发运维效率。

相关产品

  • 实时计算 Flink版
  • 相关电子书

    更多
    Spring Cloud Alibaba - 重新定义 Java Cloud-Native 立即下载
    The Reactive Cloud Native Arch 立即下载
    JAVA开发手册1.5.0 立即下载