开发者社区 > 视觉智能 > 正文

视觉智能平台php 20191230 安装失败呀,是什么原因呢?

视觉智能平台php composer.phar require alibabacloud/facebody-20191230 安装失败呀,是什么原因呢?
our requirements could not be resolved to an installable set of packages.

Problem 1

- alibabacloud/facebody-20191230[0.1.7, ..., 0.1.15] require alibabacloud/tea-oss-utils ^0.2.0 -> satisfiable by alibabacloud/tea-oss-utils[0.2.0, 0.2.1, 0.2.2, 0.2.3].
- alibabacloud/facebody-20191230[0.1.2, ..., 0.1.6] require alibabacloud/tea-oss-sdk ^0.2.2 -> satisfiable by alibabacloud/tea-oss-sdk[0.2.2].
- alibabacloud/tea-oss-utils[0.2.0, ..., 0.2.2] require ralouphie/mimey ^2.1 -> satisfiable by ralouphie/mimey[2.1.0].
- alibabacloud/facebody-20191230[3.0.5, ..., 3.0.9, 4.0.0, ..., 4.1.0] require alibabacloud/tea-oss-utils ^0.3.1 -> satisfiable by alibabacloud/tea-oss-utils[0.3.1].
- alibabacloud/facebody-20191230[2.0.6, ..., 2.0.9, 3.0.0, ..., 3.0.4] require alibabacloud/tea-oss-utils ^0.3.0 -> satisfiable by alibabacloud/tea-oss-utils[0.3.0, 0.3.1].
- alibabacloud/facebody-20191230[0.1.0, ..., 0.1.1] require alibabacloud/tea-utils ^0.1.0 -> found alibabacloud/tea-utils[0.1.0] but the package is fixed to 0.2.19 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.
- alibabacloud/tea-oss-sdk 0.2.2 requires alibabacloud/tea-xml ^0.1.0 -> found alibabacloud/tea-xml[0.1.0] but the package is fixed to 0.2.4 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.
- alibabacloud/facebody-20191230 0.1.10 requires alibabacloud/openplatform-20191219 0.2.10 -> found alibabacloud/openplatform-20191219[dev-master, 0.1.0, ..., 0.2.9, 1.0.0, 1.0.1, 1.0.2, 1.0.3, 2.0.0, 2.0.1] but it does not match the constraint.
- alibabacloud/facebody-20191230[1.0.0, ..., 1.0.5] require alibabacloud/darabonba-openapi ^0.1.0 -> found alibabacloud/darabonba-openapi[0.1.0, ..., 0.1.9] but it conflicts with your root composer.json require (^0.2.9).
- alibabacloud/facebody-20191230[1.0.6, ..., 1.0.7] require alibabacloud/darabonba-openapi ^0.1.1 -> found alibabacloud/darabonba-openapi[0.1.1, ..., 0.1.9] but it conflicts with your root composer.json require (^0.2.9).
- alibabacloud/facebody-20191230[1.0.8, ..., 1.0.14] require alibabacloud/darabonba-openapi ^0.1.8 -> found alibabacloud/darabonba-openapi[0.1.8, 0.1.9] but it conflicts with your root composer.json require (^0.2.9).
- alibabacloud/facebody-20191230 1.0.15 requires alibabacloud/darabonba-openapi ^0.1.9 -> found alibabacloud/darabonba-openapi[0.1.9] but it conflicts with your root composer.json require (^0.2.9).
- alibabacloud/facebody-20191230[1.0.16, ..., 1.0.18, 2.0.0] require alibabacloud/openapi-util ^0.1.9 -> found alibabacloud/openapi-util[0.1.9, ..., 0.1.13] but the package is fixed to 0.2.1 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.
- alibabacloud/facebody-20191230[2.0.1, ..., 2.0.5] require alibabacloud/openapi-util ^0.1.10 -> found alibabacloud/openapi-util[0.1.10, 0.1.11, 0.1.12, 0.1.13] but the package is fixed to 0.2.1 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.
- ralouphie/mimey 2.1.0 requires php ^5.4|^7.0 -> your php version (8.0.26) does not satisfy that requirement.
- alibabacloud/tea-oss-utils[0.2.3, ..., 0.3.1] require guzzlehttp/psr7 ^1.0 -> found guzzlehttp/psr7[1.0.0, ..., 1.9.1] but the package is fixed to 2.6.0 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.
- Root composer.json requires alibabacloud/facebody-20191230 * -> satisfiable by alibabacloud/facebody-20191230[0.1.0, ..., 0.1.15, 1.0.0, ..., 1.0.18, 2.0.0, ..., 2.0.9, 3.0.0, ..., 3.0.9, 4.0.0, 4.0.1, 4.1.0].

Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.
You can also try re-running composer require with an explicit version constraint, e.g. "composer require alibabacloud/facebody-20191230:*" to figure out if any version is installable, or "composer require alibabacloud/facebody-20191230:^2.1" if you know which you need.

展开
收起
嘟嘟嘟嘟嘟嘟 2024-01-10 07:52:34 25 0
2 条回答
写回答
取消 提交回答
  • 面对过去,不要迷离;面对未来,不必彷徨;活在今天,你只要把自己完全展示给别人看。

    根据提供的错误信息,问题出在PHP版本不满足依赖包的要求。alibabacloud/facebody-20191230 需要 PHP 7.0 或更高版本,而您的系统使用的是 PHP 8.0.26。

    要解决这个问题,您可以尝试以下方法:

    1. 升级您的PHP版本到7.0或更高版本。您可以从官方网站下载并安装最新版本的PHP。

    2. 如果您不想升级PHP版本,可以尝试使用Composer的--ignore-platform-reqs选项来忽略平台要求。这将允许您安装与当前系统不兼容的包。请注意,这可能会导致其他问题,因为您可能会遇到与系统不兼容的依赖包。要使用此选项,请运行以下命令:

    composer require alibabacloud/facebody-20191230 --ignore-platform-reqs
    

    请注意,这种方法可能会导致其他问题,因此建议首先尝试升级PHP版本。

    2024-01-10 14:12:00
    赞同 展开评论 打赏
  • 版本指定到4.1.0呢
    composer require alibabacloud/facebody-20191230 4.1.0
    此回答整理自钉群“阿里云视觉智能开放平台咨询1群”

    2024-01-10 10:20:17
    赞同 展开评论 打赏

为开发者提供高易用、普惠的视觉API服务,帮助企业快速建立视觉智能技术应用能力的综合性视觉AI能力平台。适用于数字营销、互联网娱乐、安防、手机应用、泛金融身份认证等行业。

相关产品

  • 视觉智能开放平台
  • 热门讨论

    热门文章

    相关电子书

    更多
    阿里云栖开发者沙龙PHP技术专场-RabbitMQ 的延时队列和镜像队列原理与实战-钱文品 立即下载
    阿里云栖开发者沙龙PHP技术专场-聊聊服务稳定性保障这些事-信海龙 立即下载
    利用CNN实现无需联网的图像识别 立即下载