开发者社区 > 云存储 > 正文

块存储测试扩1个G,发现报错 sfdisk没有 -C参数?

块存储测试扩1个G,发现报错 sfdisk没有 -C参数?LSB Version: :core-4.1-amd64:core-4.1-noarch

展开
收起
真的很搞笑 2023-10-07 16:30:48 78 0
3 条回答
写回答
取消 提交回答
  • 系统上的 sfdisk 版本较旧,不支持 "-C" 参数

    2023-10-11 21:05:48
    赞同 展开评论 打赏
  • 根据你提供的信息,sfdisk报错没有 -C 参数。这可能是因为不同版本的 Linux 发行版或 sfdisk 工具版本之间存在差异。

    在较新的版本中,特别是使用较新的 Linux 发行版时,-C 参数可能已被废弃或移除。因此,在你所使用的系统中,sfdisk 可能不再支持 -C 参数。

    建议你检查一下你所使用的 Linux 发行版和 sfdisk 的版本,并查阅相应的文档来确定正确的参数或方法来实现你想要扩展块存储的操作。

    另外,还可以尝试使用其他命令或工具来扩展块存储,例如使用 parted、fdisk 或 resize2fs 等工具,具体取决于你的系统和文件系统类型。

    2023-10-08 13:44:15
    赞同 展开评论 打赏
  • 看一下是什么操作系统版本
    lsb_release -a,CentOS 8 系统使用了 7 的 yum repo,导致安装了低版本的 growpart(cloud-utils-growpart-0.27-20.1)
    与自带的高版本(2.32.1)fdisk 不匹配导致。需要重新安装系统对应版本 growpart(cloud-utils-growpart-0.29)。,此回答整理自钉群“块存储云盘扩容专项-客户群”

    2023-10-07 16:32:19
    赞同 展开评论 打赏

阿里云存储基于飞天盘古2.0分布式存储系统,产品多种多样,充分满足用户数据存储和迁移上云需求。

相关产品

相关电子书

更多
移动互联网测试到质量的转变 立即下载
给ITer的技术实战进阶课-阿里CIO学院独家教材(四) 立即下载
F2etest — 多浏览器兼容性测试整体解决方案 立即下载