开发者社区> 问答> 正文

阿里云OpenAPI 项目已经是php8了,换php7成本太大了,php7.4可以吗?

阿里云OpenAPI 项目已经是php8了,换php7成本太大了,php7.4可以吗?image.png
image.png

展开
收起
三分钟热度的鱼 2023-09-05 20:42:11 81 0
1 条回答
写回答
取消 提交回答
  • 全栈JAVA领域创作者

    阿里云OpenAPI支持的PHP版本是根据OpenAPI规范的版本来确定的,而不是根据具体的PHP版本来确定的。因此,只要OpenAPI规范支持的PHP版本,阿里云OpenAPI都可以支持。
    目前,OpenAPI规范支持的PHP版本包括PHP 7.4.x和PHP 8.x.x。因此,如果您的项目已经是PHP 8了,那么可以继续使用PHP 8。如果您的项目是PHP 7.4.x,那么也可以使用PHP 7.4.x。
    总之,阿里云OpenAPI支持的PHP版本是根据OpenAPI规范的版本来确定的,只要OpenAPI规范支持的PHP版本,阿里云OpenAPI都可以支持。

    2023-09-07 13:34:33
    赞同 展开评论 打赏
问答排行榜
最热
最新

相关电子书

更多
阿里云栖开发者沙龙PHP技术专场-深入浅出网络编程与swoole内核-吴镇宇 立即下载
PHP 2017.北京 全球开发者大会——高可用的PHP 立即下载
最大化阿里云OpenAPI能力的方法和实践 立即下载