开发者社区> 问答> 正文

请问druid是否支持POLARDB(oracle)数据库?到底是用poardb驱动还是用postg

请问druid是否支持POLARDB(oracle)数据库?到底是用poardb驱动还是用postgresql驱动?

原提问者GitHub用户cdh-dev

展开
收起
山海行 2023-07-05 19:27:40 90 0
3 条回答
写回答
取消 提交回答
  • 北京阿里云ACE会长

    对于PolarDB for Oracle版本,需要使用Oracle驱动来配置Druid。对于不同的PolarDB版本:

    PolarDB for Oracle,使用Oracle驱动配置Druid
    PolarDB for PostgreSQL,使用PostgreSQL驱动配置Druid

    2023-07-30 16:45:17
    赞同 展开评论 打赏
  • Druid本身是一个数据库连接池,它本身并不提供对具体数据库的支持,而是依赖于底层数据库驱动来实现与数据库的通信。因此,Druid的支持取决于使用的数据库驱动是否支持。

    对于POLARDB(Oracle兼容)数据库,您可以使用Oracle驱动或者PostgreSQL驱动来与之通信,具体取决于您所使用的数据库的兼容性和要求。

    2023-07-11 09:29:50
    赞同 展开评论 打赏
  • 目前还不支持。但可以使用 polardb 的驱动,正确配置驱动名就可以,dbType可以指定为 postgresql。

    原回答者GitHub用户ldming

    2023-07-06 10:55:31
    赞同 展开评论 打赏
问答排行榜
最热
最新

相关电子书

更多
2022 DTCC-阿里云一站式数据库上云最佳实践 立即下载
云时代的数据库技术趋势 立即下载
超大型金融机构国产数据库全面迁移成功实践 立即下载

相关镜像