开发者社区> 问答> 正文

以前一直好好的 为什么今天springboot的jar包中,parent标签一?报错

以前一直好好的 为什么今天springboot的jar包中,parent标签一直报错,我强制更新
maven很多次了,也没用!!!,因为这个导致我项目很多注解失效!

图片说明

这是parent节点的报错说明:
Project configurator "org.springframework.ide.eclipse.boot.properties.editor.maven.EnableJdtAptM2EProjectConfigurator" required by plugin execution "org.apache.maven.plugins:maven-compiler-plugin:3.7.0:testCompile (execution: default-testCompile, phase: test-compile)" is not available. To enable full functionality, install the project configurator and run Maven->Update Project Configuration.

展开
收起
爱吃鱼的程序员 2020-06-23 01:33:28 502 0
1 条回答
写回答
取消 提交回答
  • https://developer.aliyun.com/profile/5yerqm5bn5yqg?spm=a2c6h.12873639.0.0.6eae304abcjaIB

    碰到此类问题,可以尝试以下几种方案:
    1、确认时候改动pom.xml文件,查看是否改动或者不小心改动了dependency代码,或者有没有重复的dependency等,是不是写错groupId、artifactId、version各项内容等;
    2、尝试Project->Clean命令;看是否可以解决此问题;
    3、使用MavenClean,MavenInstall看是都可以解决问题;
    4、到.m2/repository目录下面,找到对应的包,看看是否存在对应的jar包,如果没有对应的jar,可能是没有该版本的jar,也可能是settings.xml配置错误等,导致没有从maven库里面拉取到对应的jar,如下图:

    5、有时候可能是eclipse的问题,重启一下,或者切换到其他workspace,然后再切换回来,可能会解决;
    6、删除maven项目,然后重新Import一下maven项目。

    你可以新建一个springboot项目试试看会不会报错,如果不会报错对比下2者的差别。如果还不能确定问题可以将旧项目代码移至新建项目中看下情况

    应该是本地仓库中这个包出了问题,IDEA没有解析出来。可以进入本地仓库,把这个包删除,然后用maven更新pom文件就好了。文件位置:.m2/repository/org/springframework/boot/

    是不是:maven-compiler-plugin的插件版本太高导致的呢

    如果不是pom里面写错的问题话,我估计是切换环境的时候下载boot的依赖包出现了问题,导致jar包有错。
    但是现在不能明确知道是哪个依赖有问题。
    提供方法:
    1.删除里maven仓库下org文件夹下的springframework文件夹下的boot文件夹,把springboot的所有依赖全部删除重新下载。
    2.直接重新换一个maven仓库,重新下载所有需要的项目依赖。

    应该是版本问题导致的

    不好意思各位亲今天又突然好了MyEclipse真是玄学……

    2020-06-23 01:33:45
    赞同 展开评论 打赏
问答排行榜
最热
最新

相关电子书

更多
使用Spring.Initializr定制工程脚手架 立即下载
陈曦:使用Spring.Initializr定制工程脚手架 立即下载
低代码开发师(初级)实战教程 立即下载

相关实验场景

更多