安卓引用R.layout报错,sdk版本问题 ?报错-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文
阿里云
为了无法计算的价值
打开APP
阿里云APP内打开

安卓引用R.layout报错,sdk版本问题 ?报错

如题,本来是import appcompatv7报错,而且下面调用R.layout报错。sdk版本最低选择的是2.2,target 版本选择的是4.03,编译版本选择的是4.03。
我按照网上其他的项目包含文件改了还是报错。没有包含android.R。假如包含android.R可以调用R.layout,但是找不到layout下面的xml文件。
还有一个问题是本来能显示xml的图形界面,我更新了sdk后图形界面也不显示了

展开
收起
爱吃鱼的程序员 2020-06-23 00:48:22 427 0
1 条回答
写回答
取消 提交回答
  • 爱吃鱼的程序员
    https://developer.aliyun.com/profile/5yerqm5bn5yqg?spm=a2c6h.12873639.0.0.6eae304abcjaIB

    clean一下,然后看看你xml文件有没有什么问题

    2020-06-23 00:48:39
    赞同 展开评论 打赏
问答排行榜
最热
最新
相关电子书
更多
Android组件化实现
立即下载
蚂蚁聚宝Android秒级编译—— Freeline
立即下载
Android插件化:从入门到放弃
立即下载