spring和Velocity的配置问题?报错-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文

spring和Velocity的配置问题?报错

爱吃鱼的程序员 2020-06-22 20:43:00 94

配置信息如下:


<bean id="viewResolver" class="org.springframework.web.servlet.view.velocity.VelocityViewResolver"> <property name="cache" value="true"/> <property name="prefix" value=""/> <property name="suffix" value=".vm"/> </bean> <bean id="velocityConfig" class="org.springframework.web.servlet.view.velocity.VelocityConfigurer"> <property name="resourceLoaderPath" value="/WEB-INF/velocity/" /> </bean>
 我WEB-INF的文件结构如下


启动tomcat报错信息如下


org.springframework.beans.factory.CannotLoadBeanClassException: Error loading class [org.springframework.web.servlet.view.velocity.VelocityConfigurer] for bean with name 'velocityConfig' defined in ServletContext resource [/WEB-INF/admin-servlet.xml]: problem with class file or dependent class; nested exception is java.lang.NoClassDefFoundError: org/springframework/ui/velocity/VelocityEngineFactory



我检查了我lib下面的包,报错的那个包是存在的。

问题一:为什么会提示我找不到那个类,实际上那个类是已经存在的。

问题二:我看到错误信息里面有类似于

Caused by: java.lang.NoClassDefFoundError: org/springframework/ui/velocity/VelocityEngineFactory


的信息,确实我里面没这个包。org/springframework/ui/这个包是干嘛的,我上网也没找到相关的信息。



Java 应用服务中间件 Spring
分享到
取消 提交回答
全部回答(1)
  • 爱吃鱼的程序员
    2020-06-22 20:43:16

    试试这个。add <spanstyle="font-family:微软雅黑,Verdana,sans-serif,宋体;font-size:14px;line-height:normal;background-color:#FFFFFF;">spring-context-support.jar<preclass="brush:xml;toolbar:true;auto-links:false;"><beans:beanid="velocityConfig"class="org.springframework.web.servlet.view.velocity.VelocityConfigurer"><beans:propertyname="velocityProperties"><beans:props><beans:propkey="input.encoding">utf-8</beans:prop><beans:propkey="output.encoding">utf-8</beans:prop><beans:propkey="resource.loader">file</beans:prop><beans:propkey="file.resource.loader.path">WEB-INF/classes/vm/</beans:prop><beans:propkey="file.resource.loader.class">org.apache.velocity.tools.view.servlet.WebappLoader</beans:prop><beans:propkey="file.resource.loader.cache">false</beans:prop><beans:propkey="file.resource.loader.modificationCheckInterval">1</beans:prop><beans:propkey="velocimacro.library">macro.vm</beans:prop></beans:props></beans:property></beans:bean><beans:beanid="viewResolver"class="org.springframework.web.servlet.view.velocity.VelocityViewResolver"><beans:propertyname="cache"value="false"/><beans:propertyname="prefix"value=""/><beans:propertyname="suffix"value=".vm"/><beans:propertyname="contentType"value="text/html;charset=UTF-8"/><beans:propertyname="exposeSessionAttributes"value="true"/><!--velocity-toolbox.xml配置文件--><beans:propertyname="toolboxConfigLocation"value="WEB-INF/classes/config/velocity-toolbox.xml"/></beans:bean>
    回复<aclass='referer'target='_blank'>@冻鱼:版本错误,这确实难谢谢你,不过还是不行。

    配置信息的排版很难看,我还是截图吧,看着比较清晰。

    <imgsrc="http://static.oschina.net/uploads/space/2013/0329/163340_dTbW_103060.jpg"alt=""/>

    之前我也遇到过。哥们,你是怎么解决啊

    报错的版本是:3.2.2.RELEASE

    改成:3.1.3.RELEASE

    就OK了~~~~~~~

    缺少spring-context-support.jar包。

    spring-webmvc3.2.2默认没有引用它,加到项目里来就可以了。

    非常感谢!谢谢

    0 0
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

推荐文章
相似问题
推荐课程