Centos 6.4 源码安装mysql5.6.10 报错?报错-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文

Centos 6.4 源码安装mysql5.6.10 报错?报错

爱吃鱼的程序员 2020-06-22 14:25:46 29

centos 6.4 源码安装mysql 5.6.10 ,出现上面的错误,求大神!!!!

JavaScript 关系型数据库 MySQL Linux
分享到
取消 提交回答
全部回答(1)
  • 爱吃鱼的程序员
    2020-06-22 14:26:04

    给得给好评啊

    1. yum install  libevent*  libtool* autoconf* libstd* gcc44* ncurse* bison* openssl* cmake*

    2.  mysql 5.5 开始需要 cmake 支持才能安装

    # 检查 cmake 是否已经安装(如果以下命令出错,就需要安装 cmake )

    cmake 下载地址 http://www.cmake.org/cmake/resources/software.html

      cmake --version

    tar -xf cmake-2.8.10.2.tar.gz

    cd cmake-2.8.10.2

    ./configure && make && make install

      # 再次验证

    cmake --version

    tar -xf mysql-5.5.30.tar.gz

    cd  mysql-5.5.30

     

    cmake .  -DCMAKE_INSTALL_PREFIX=/usr/local/mysql \

    -DMYSQL_DATADIR=/data/mysql \

    -DWITH_ARCHIVE_STORAGE_ENGINE=ON \

    -DWITH_BLACKHOLE_STORAGE_ENGINE=ON \

    -DWITH_DEBUG=OFF \

    -DWITH_EXTRA_CHARSETS=all \

    -DWITH_FEDERATED_STORAGE_ENGINE=ON \

    -DWITH_INNOBASE_STORAGE_ENGINE=ON \

    -DWITH_PARTITION_STORAGE_ENGINE=ON \

    -DWITH_PERFSCHEMA_STORAGE_ENGINE=ON \

    -DWITH_UNIT_TESTS=OFF

     

    make && make install


    重新源码安装了最新的cmake,就可以了cmake我安装了,cmakeversion2.6-patch4然后下面的参数也设置了,还是不行 yuminstallmakeapr*autoconfautomakegccgcc-c++zlib-developensslopenssl-develpcre-develgdkernelkeyutilspatchperlkernel-headerscompat*mpfrcppglibclibgomplibstdc++-develpplcloog-pplkeyutils-libs-devellibcom_err-devellibsepol-devellibselinux-develkrb5-develzlib-devellibXpm*freetypelibjpeg*libpng*php-commonphp-gdncurses*libtool*libxml2libxml2-develpatchlibxml2-developenssl-develcurl-devellibjpeg-devellibpng-develpcre-devellibtool-libsfreetype-develgdzlib-develfilebisonpatchmlocateflexdiffutilsreadline-develglibc-develglib2-develbzip2-develgettext-devellibcap-devellibmcrypt-devel yuminstallmakeapr*autoconfautomakegccgcc-c++zlib-developensslopenssl-develpcre-develgdkernelkeyutilspatchperlkernel-headerscompat*mpfrcppglibclibgomplibstdc++-develpplcloog-pplkeyutils-libs-devellibcom_err-devellibsepol-devellibselinux-develkrb5-develzlib-devellibXpm*freetypelibjpeg*libpng*php-commonphp-gdncurses*libtool*libxml2libxml2-develpatchlibxml2-developenssl-develcurl-devellibjpeg-devellibpng-develpcre-devellibtool-libsfreetype-develgdzlib-develfilebisonpatchmlocateflexdiffutilsreadline-develglibc-develglib2-develbzip2-develgettext-devellibcap-devellibmcrypt-develcmake.-DCMAKE_INSTALL_PREFIX=/usr/local/mysql-DMYSQL_DATADIR=/data/mysql-DSYSCONFDIR=/etcmakemakeinstall

    说句难听的,有本事就玩LFS,全部源码安装,自己写makefile,别用任何包管理软件,搞得不伦不类。

    没本事就乖乖yum/apt。

    没那金刚钻,别揽瓷器活。

    直接去mysql的官方网站上下载啊,下玩了直接rpm啊,rpm之前记得安装好gcc。
    0 0
数据库
使用钉钉扫一扫加入圈子
+ 订阅

分享数据库前沿,解构实战干货,推动数据库技术变革

推荐文章
相似问题