开发者社区> 问答> 正文

Linux mysql rpm包安装的问题?报错

在Linux6.4 x86下安装mysql5.5后,启动报错

 

我安装的mysql包:

 

总共就装了这3个包,感觉像是装server的时候出问题了,该如何解决啊!!!求大神帮忙,谢谢

 

 

 

展开
收起
爱吃鱼的程序员 2020-06-22 10:49:09 418 0
1 条回答
写回答
取消 提交回答
  • https://developer.aliyun.com/profile/5yerqm5bn5yqg?spm=a2c6h.12873639.0.0.6eae304abcjaIB

    我安装了client和server端两个rpm包,在redhat上面可以正常启动,去网上找找答案来的快点

    嗯,谢谢,已经找到了,包有冲突

    直接编译安装吧,参见我blog里的。

    谢谢,我不想装源码的想装个RPM的

    rpm安装挺简单的,没mysqld服务应该就是server包安装,可以通过yum安装。

    回复 @雲淡風輕:也有比较新的源,但是要最新的那就去官网下,有rpm的,但是最新的都是源码的yum装的版本太低了

    写一个my.cnf到/etc里

    yum-yremovemysql-libs

    谢谢大神,按你说的做就OK了

    包有冲突


    2020-06-22 10:49:28
    赞同 展开评论 打赏
问答排行榜
最热
最新

相关电子书

更多
PolarDB-X:更具性价比的 MySQL替换 立即下载
2023云栖大会:AnalyticDB MySQL新特性介绍 立即下载
2023云栖大会:云数据库RDS - 年度产品发布与最佳实践 立即下载