VirtualBox安装Ubuntu中使用make sanity报ant版本错误!?报错-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文

VirtualBox安装Ubuntu中使用make sanity报ant版本错误!?报错

爱吃鱼的程序员 2020-06-12 11:06:12 76

环境:VirtualBox里的Ubuntu

目的:打算深入理解JAVA虚拟机,编译JDK。

实际操作:搭好环境并且装完对应依赖后,基于OpenJDK7u4打算进行编译。用make sanity后报错:

ERROR: The version of ant being used is older than 
the required version of '1.7.1'. 
The version of ant found was '1.7.0'.

但是实际环境中ant的版本是:

ant -version
Apache Ant(TM) version 1.9.6 compiled on June 29 2015。

不知道make sanity的时候是怎么检查ant的version的。求大神帮忙解答!非常感谢!

Ubuntu Java Apache
分享到
取消 提交回答
全部回答(1)
  • 爱吃鱼的程序员
    2020-06-12 11:06:30

    我遇到了同样的问题,不要自己安装ant了,然后自己使用sudoapt-getinstallant 

    同时,你安装之后可能有同样的问题,


    很可能是需要退出当前shell窗口,然后再次登录主机下,就ok了,

    如果还不行,whichant还有whereant,看看本机是否还有其他地方有ant


    祝好运

    这个具体原因不详,虚拟机中会出现这种情况,后来弄了台电脑装ubuntu系统,再操作的时候就不会出现上述问题了。有可能是跟master里已经安装的ant冲突吧!谢谢回复!
    0 0
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

推荐文章
相似问题
推荐课程