安装总报错, python 2.7.10 ,nodejs 4.2.1?报错-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文

安装总报错, python 2.7.10 ,nodejs 4.2.1?报错

爱吃鱼的程序员 2020-06-10 11:16:27 109

npm ERR! Linux 2.6.32-573.7.1.el6.x86_64
npm ERR! argv "/ROOT/server/nodejs/bin/node" "/ROOT/server/nodejs/bin/npm" "install" "log.io" "-g"
npm ERR! node v4.2.1
npm ERR! npm  v2.14.7
npm ERR! code ELIFECYCLE


npm ERR! contextify@0.1.14 install: node-gyp rebuild
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the contextify@0.1.14 install script 'node-gyp rebuild'.
npm ERR! This is most likely a problem with the contextify package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node-gyp rebuild
npm ERR! You can get their info via:
npm ERR!     npm owner ls contextify
npm ERR! There is likely additional logging output above.


npm ERR! Please include the following file with any support request:
npm ERR!     /ROOT/server/nodejs/lib/node_modules/npm-debug.log


JavaScript Linux Python
分享到
取消 提交回答
全部回答(1)
  • 爱吃鱼的程序员
    2020-06-10 11:16:43

    少装了模块 node-gyp,使用npm在线安装: npminstallnode-gyp

    0 0
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

推荐文章
相似问题
推荐课程