ubuntu安装mysql,报错“Version '5.7.10-1ubuntu?报错-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文

ubuntu安装mysql,报错“Version '5.7.10-1ubuntu?报错

爱吃鱼的程序员 2020-06-09 14:16:24 67
 大神们,我想安装mysql, 用这个命令安装sudo apt-get install mysql-server=5.7.10-1ubuntu14.04,报错“Version '5.7.10-1ubuntu14.04' for 'mysql-server' was not found”。执行命令前,已下载文件mysql-server_5.7.10-1ubuntu14.04_amd64.deb,放在存储deb文件的位置。 
存储 Ubuntu 关系型数据库 MySQL
分享到
取消 提交回答
全部回答(1)
  • 爱吃鱼的程序员
    2020-06-09 14:16:42

    apt-get是在线安装;

    既然已经下载好deb,那就应该用dpkg进行解包安装; 

    试试 sudodpkg-i  mysql-server_5.7.10-1ubuntu14.04_amd64.deb(安装包文件在当前目录,不在当前目录请加上正确的目录)


    回复 @Feng_Yu:谢谢!这次我下载了tar后缀的文件,这个文件包含了相关的deb文件,用命令dpkg和apt-get-finstall,安装成功了。回复 @开心快乐每一天:请看mysql官方文档:https://dev.mysql.com/downloads/repo/apt/回复 @Feng_Yu:你好,提高“加mysql官方仓库”这个操作,能否举个例子看下。比如mysql官方仓库地址,加在哪里。感谢。回复 @开心快乐每一天:自己加mysql官方仓库解决这些依赖。ubuntu14.04官方仓库是没有5.7的使用dpkg命令安装,报错"dpkg:dependencyproblemspreventconfigurationofmysql-server"。大神,怎么解决这个依赖问题呢?

    在线安装呗,sudoapt-getinstallmysql

    嗯,主要考虑到,在实际开发时,要安装指定的稳定的版本。
    0 0
数据库
使用钉钉扫一扫加入圈子
+ 订阅

分享数据库前沿,解构实战干货,推动数据库技术变革

推荐文章
相似问题