配置 spring security时,启动tomcat就报错了:配置报错 -问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文

配置 spring security时,启动tomcat就报错了:配置报错 

kun坤 2020-06-02 19:30:19 70

各位大神好,我在配置spring security 时,按网上配置,但是一启动 tomcat 就报错了,错误信息和配置如下图

安全 Java 应用服务中间件 Spring
分享到
取消 提交回答
全部回答(1)
  • kun坤
    2020-06-02 19:30:26

    字体太小######spring-core这个包,你看你的依赖里有没有,有的话看看有没有org.springframeworker.util.AntPathMatcher这个类,没有的话可能是版本不对。######更新一下spring-core的版本 看了下源码4.1没有 setCaseSensitive ######

    引用来自“公子千”的评论

    spring-core这个包,你看你的依赖里有没有,有的话看看有没有org.springframeworker.util.AntPathMatcher这个类,没有的话可能是版本不对。 这个包,这个类都是有的######

    引用来自“这里的名字只能十个字”的评论

    更新一下spring-core的版本 看了下源码4.1没有 setCaseSensitive 难道真是版本不对吗 ?这个方法确实 没有,可spring securtity是 4.1.3的(目前最新的),难道我的spring不应该也要对应版本一样吗######

    引用来自“这里的名字只能十个字”的评论

    更新一下spring-core的版本 看了下源码4.1没有 setCaseSensitive

    引用来自“我是来这里找女朋友的”的评论

    难道真是版本不对吗 ?这个方法确实 没有,可spring securtity是 4.1.3的(目前最新的),难道我的spring不应该也要对应版本一样吗 版本还要看实际情况而定,spring-security和spring-core是两个项目,版本不一致很正常,如果ss用的是最新版本的话,建议你也配合spring的最新版本使用,目前是4.3.3.RELEASE,帮你看过了,最新版本是有这段方法的
    0 0
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

推荐文章
相似问题
推荐课程