用eclipse构建maven项目,依赖包无法正常下载:配置报错 -问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文

用eclipse构建maven项目,依赖包无法正常下载:配置报错 

kun坤 2020-06-02 18:04:02 52

在POM.XML文件中配置好后,点确定,过了一会儿发现有报错

Description	Resource	Path	Location	Type The container 'Maven Dependencies' references non existing library 'C:\Users\WL.m2\repository\org\springframework\spring-core${spring.version}\spring-core-${spring.version}.jar'	springmvc2		Build path	Build Path Problem
然后发现是下载依赖包的时候出问题了,下载的文件都有个.lastUpdated的后缀,删除该文件后,右击项目,maven-->update project   点击确定,发现下载的新的包还是有这个后缀,并且大小只有1KB,百度了一下,又右击项目, maven-->update project ,勾选Force Update of........ 点确定后发现下载的还是有那个后缀,这下没办法了。百度查了一下都说删了重下就OK的,结果我的一直都是那样。求大家帮帮忙。注:仓库网页可以正常访问,也可以下载。

Java Maven Android开发 容器
分享到
取消 提交回答
全部回答(1)
  • kun坤
    2020-06-02 18:04:10

    你的配置里面对spring 的版本使用了变量${spring.version},但是没有配置相关的变量,你需要在<properties>里面配置一个<spring.version>x.y.z</spring.version>然后就可以了

    ######感谢 OK了###### 支持一楼说法看下spring.version 有没有定义
    可以使用man clean install -e 打印错误消息 ######支持一楼说法

    0 0
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

推荐文章
相似问题
推荐课程