钉钉自定义机器人接入问题-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文

钉钉自定义机器人接入问题

机器人110 2017-02-20 15:43:29 20606
钉钉自定义机器人接入问题
我现在在接入钉钉自定义机器人功能,调用robot/send ?access_token=xxxxxxxx
xxxxxxxx 获取接口为 /gettoken? corpid= corpid & corpsecret= corpsecret
现在调用发送消极接口报错信息:
{errmsg:"token is not exist" ,errcode:300001 }


是获取token的方式不对?还是其他的问题?
机器人
分享到
取消 提交回答
全部回答(5)
  • 游客nqszhheys3r4w
    2020-03-04 15:32:41

    [root@v-test-01 html]# curl 'https://oapi.dingtalk.com/robot/send?access_token=cbef26e235021f452be1ce46e4d9983bad8e35ca3f88xxxxxxxxxxxxx' -H 'Content-Type: application/json' -d '{"msgtype": "text", "text": { "content": "钉钉机器人群消息测试" } }' {"errcode":130101,"errmsg":"send too fast"} 请教为什么我总是提示“{"errcode":130101,"errmsg":"send too fast"}”? 检查了下各参数和格式都没问题,请指点谢谢

    0 0
  • luojingwen23
    2018-11-22 11:12:21
    Re钉钉自定义机器人接入问题
    我的钉钉不管是自定义机器人连接还是GitHub 机器人 返回的信息都是{"errmsg":"msgtype is null","errcode":300001}望解答
    0 0
  • 大饭米粒
    2017-02-28 17:45:17
    回 1楼wizard95的帖子
    我之前也出现系统繁忙,后来发现字符编码不是UTF-8,改成UTF-8之后一切正常

    -------------------------

    回 4楼wizard95的帖子
    协议头加了吗,昨天我写了一个PC版的机器人,什么格式、编码都正确的,结果返回信息提示param error,我最后发现协议头错了,改正确后一切正常。Content-Type:application/json保证大小写正确
    0 0
  • 未名工作室
    2017-02-28 16:29:44
    Re钉钉自定义机器人接入问题
    我是用PHP CURL发送的,出300001错
    0 0
  • wizard95
    2017-02-27 17:24:47
    Re钉钉自定义机器人接入问题
    楼主解决了吗?
    我在钉钉的群组里添加了一个自定义机器人,
    然后复制的HOOK地址:oapi.dingtalk.com/robot/send?access_token=xxxxxx  
    然后用php curl post方式推送,一直返回  
    {"errmsg":"系统繁忙","errcode":-1},

    POST的地址带 https://

    -------------------------

    回 3楼大饭米粒的帖子
    PHP 的json_encode 默认不就是UTF-8处理字符的吗,
    我代码都没与改,第二天之后所有报错都是:
    {"errmsg":"param error","errcode":300001}
    我现在发送的格式是:
    {"msgtype":"text","text":{"content":"\u6d4b\u8bd5\u6d4b\u8bd5"},"at":{"atMobiles":["152XXXX0170"],"isAtAll":false}}

    -------------------------

    回 5楼大饭米粒的帖子
    谢谢,果然是协议头的问题
    0 0
添加回答
云计算
使用钉钉扫一扫加入圈子
+ 订阅

时时分享云计算技术内容,助您降低 IT 成本,提升运维效率,使您更专注于核心业务创新。

推荐文章
相似问题