在linux中安装提示权限不够-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文

在linux中安装提示权限不够

dodd001 2015-02-16 13:03:04 16771
具体请看,我用的阿里云的一键web安装包搭建,刚开始提示install.sh权限不够,我给了添加了chmod 777 ./install.sh 结果安装起来的文件有些权限不够,求帮忙
Enter the y or Y to continue:Y
will be installed, wait ...
grep: /etc/issus: 没有那个文件或目录
已加载插件:fastestmirror, langpacks
base                                                     | 3.6 kB     00:00    
extras                                                   | 3.4 kB     00:00    
updates                                                  | 3.4 kB     00:00    
Loading mirror speeds from cached hostfile
* base: centos.ustc.edu.cn
* extras: mirrors.163.com
* updates: mirrors.163.com
元数据缓存已建立
已加载插件:fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* base: centos.ustc.edu.cn
* extras: mirrors.163.com
* updates: mirrors.163.com
软件包 gcc-4.8.2-16.2.el7_0.x86_64 已安装并且是最新版本
软件包 gcc-c++-4.8.2-16.2.el7_0.x86_64 已安装并且是最新版本
没有可用软件包 gcc-g77。
软件包 1:make-3.82-21.el7.x86_64 已安装并且是最新版本
软件包 libtool-2.4.2-20.el7.x86_64 已安装并且是最新版本
软件包 autoconf-2.69-11.el7.noarch 已安装并且是最新版本
软件包 patch-2.7.1-8.el7.x86_64 已安装并且是最新版本
软件包 unzip-6.0-13.el7.x86_64 已安装并且是最新版本
软件包 automake-1.13.4-3.el7.noarch 已安装并且是最新版本
软件包 libxml2-2.9.1-5.el7_0.1.x86_64 已安装并且是最新版本
软件包 libxml2-devel-2.9.1-5.el7_0.1.x86_64 已安装并且是最新版本
软件包 ncurses-5.9-13.20130511.el7.x86_64 已安装并且是最新版本
软件包 ncurses-devel-5.9-13.20130511.el7.x86_64 已安装并且是最新版本
软件包 libtool-ltdl-devel-2.4.2-20.el7.x86_64 已安装并且是最新版本
软件包 libtool-ltdl-2.4.2-20.el7.x86_64 已安装并且是最新版本
没有可用软件包 libmcrypt。
没有可用软件包 libmcrypt-devel。
软件包 2:libpng-1.5.13-5.el7.x86_64 已安装并且是最新版本
软件包 2:libpng-devel-1.5.13-5.el7.x86_64 已安装并且是最新版本
软件包 libjpeg-turbo-devel-1.2.90-5.el7.x86_64 已安装并且是最新版本
软件包 1:openssl-1.0.1e-34.el7_0.7.x86_64 已安装并且是最新版本
软件包 1:openssl-devel-1.0.1e-34.el7_0.7.x86_64 已安装并且是最新版本
软件包 curl-7.29.0-19.el7.x86_64 已安装并且是最新版本
软件包 libcurl-devel-7.29.0-19.el7.x86_64 已安装并且是最新版本
软件包 libxml2-2.9.1-5.el7_0.1.x86_64 已安装并且是最新版本
软件包 libxml2-devel-2.9.1-5.el7_0.1.x86_64 已安装并且是最新版本
软件包 ncurses-5.9-13.20130511.el7.x86_64 已安装并且是最新版本
软件包 ncurses-devel-5.9-13.20130511.el7.x86_64 已安装并且是最新版本
软件包 libtool-ltdl-devel-2.4.2-20.el7.x86_64 已安装并且是最新版本
软件包 libtool-ltdl-2.4.2-20.el7.x86_64 已安装并且是最新版本
软件包 autoconf-2.69-11.el7.noarch 已安装并且是最新版本
软件包 automake-1.13.4-3.el7.noarch 已安装并且是最新版本
软件包 libaio-0.3.109-12.el7.x86_64 已安装并且是最新版本
软件包 libaio-devel-0.3.109-12.el7.x86_64 已安装并且是最新版本
无须任何处理
tmp.log
./install.sh:行172: ./env/install_set_sysctl.sh: 权限不够
./install.sh:行173: ./env/install_set_ulimit.sh: 权限不够
./install.sh:行179: ./env/install_dir.sh: 权限不够
./install.sh:行182: ./env/install_env.sh: 权限不够
./install.sh:行185: ./mysql/install_mysql-5.1.73.sh: 权限不够
./install.sh:行189: ./nginx/install_nginx-1.4.4.sh: 权限不够
./install.sh:行191: ./php/install_nginx_php-5.5.7.sh: 权限不够
./install.sh:行200: ./php/install_php_extension.sh: 权限不够
./install.sh:行203: ./ftp/install_vsftpd-2.3.2.sh: 权限不够
./install.sh:行207: ./res/install_soft.sh: 权限不够
./install.sh:行248: /alidata/server/php/bin/php: 没有那个文件或目录
./install.sh:行267: /etc/init.d/php-fpm: 没有那个文件或目录
./install.sh:行268: /etc/init.d/nginx: 没有那个文件或目录
./install.sh:行273: /etc/init.d/vsftpd: 没有那个文件或目录
cp: 无法创建普通文件"/alidata/website-info.log": 没有那个文件或目录
cat: /alidata/website-info.log: 没有那个文件或目录
[root@localhost sh-1.4.1]# ll


求高手帮忙啊
缓存 关系型数据库 MySQL 应用服务中间件 Linux PHP nginx
分享到
取消 提交回答
全部回答(7)
  • 您好小明
    2016-01-18 17:32:26
    由于这个脚本在使用过程中,需要引用到别的脚本,这时候要求别的脚本也需要执行权限的。
    chmod -R 777 SH
    0 0
  • 11cc
    2016-01-18 17:21:48
    chmod -R 777
    0 0
  • 春蚕织梦
    2016-01-18 13:17:00
    切root,加权限就可以了
    0 0
  • 昵称已被占
    2015-06-09 10:34:54
    Re在linux中安装提示权限不够
    chmod -R 755 sh 是给sh目录及下属文件付权限,你安装错误说明上是env,php等等的目录没有权限,这些目录你也开权限试试
    0 0
  • peterluo
    2015-06-09 09:14:04
    回2楼tony120282的帖子
    这个亲测有用,给所有的文件赋权限
    0 0
滑动查看更多
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

推荐文章
相似问题