ubuntu10.1064位云服务器如何升级php-问答-阿里云开发者社区-阿里云

开发者社区> 问答> 正文

ubuntu10.1064位云服务器如何升级php

qxzhu 2013-03-31 10:55:50 8896
我看了下原有的php安装在/alidata/server下,版本是php5.2.17,想升级到最新版。
我输入php -v为什么说我没有安装php呢?
/php# php -v
The program 'php' is currently not installed.  You can install it by typing:
apt-get install php5-cli

用apt-get是全新安装
apt-get install php5-cli
Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following extra packages will be installed:
  php5-common
Suggested packages:
  php-pear php5-suhosin
The following NEW packages will be installed:
  php5-cli php5-common
0 upgraded, 2 newly installed, 0 to remove and 37 not upgraded.
Need to get 3,588kB of archives.
After this operation, 9,142kB of additional disk space will be used.
Do you want to continue [Y/n]?
也不知道这个全新安装会装在哪个地方?,版本会是多少?
PHP
分享到
取消 提交回答
全部回答(2)
  • qxzhu
    2013-03-31 11:23:29
    回1楼twl007的帖子
    谢谢版主解决了我的两个疑问。如果我想直接在原有的php5.2.17上升级的话,应该如何操作呢?

    -------------------------

    回3楼twl007的帖子
    服务器不是用apache用的是nginx.我按你的思路先试试看。谢谢版主
    0 0
  • twl007
    2013-03-31 11:05:42
    回 楼主(qxzhu) 的帖子
    因为阿里云的php安装并没有包含在系统的环境变量里 你需要手动添加那个目录到系统环境变量里才能直接使用

    如果全新安装的php应该是/usr/bin里面 或者安装完后手动输入 find / | grep php 来查找一下

    -------------------------

    回 2楼(qxzhu) 的帖子
    这个比较麻烦了吧 建议直接安装php5.3在系统里面 然后修改apache的配置调用系统的php
    因为没见阿里他们怎么配的所以不知道具体情况
    可以的话把服务器ip及密码告诉我下 我需要登陆看看才能知道怎么弄
    因为Ubuntu下的apache可以使用fcgi的 或许可以通过fcgi来调用系统的自带php

    -------------------------

    回 4楼(qxzhu) 的帖子
    Nginx就简单了 - -
    你Ubuntu上装好php-5.3 然后启动php-fpm 之后设定Nginx将php处理发向php-fpm就行了
    实在是抱歉 centos用多了忘了Ubuntu他软件功能全面了 9 9
    0 0
添加回答
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

推荐文章
相似问题