开发者社区> 问答> 正文

阿里云ecs的linux系统下的命令yum -y install mysql-community-server 无法安装mysql包,求大神指点

真阿民 2018-12-27 10:13:38 894

rpm: RPM should not be used directly install RPM packages, use Alien instead!
rpm: However assuming you know what you are doing...
Preparing... ################################# [100%]

package mysql-community-release-el7-5.noarch is already installed

root@caisheng:/#
root@caisheng:/# ls -1 /etc/yum.repos.d/mysql-community*
/etc/yum.repos.d/mysql-community.repo
/etc/yum.repos.d/mysql-community-source.repo
root@caisheng:/# yum install mysql-server
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package mysql-community-server.x86_64 0:5.6.42-2.el7 will be installed
--> Processing Dependency: mysql-community-common(x86-64) = 5.6.42-2.el7 for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: mysql-community-client(x86-64) >= 5.6.10 for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: systemd for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: systemd for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: shadow-utils for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: rtld(GNU_HASH) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: procps for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(warnings) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(strict) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(if) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(Sys::Hostname) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(POSIX) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(Getopt::Long) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(File::Temp) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(File::Spec) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(File::Path) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(File::Copy) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(File::Basename) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(Fcntl) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(Data::Dumper) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(DBI) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: net-tools for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.9)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.11)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libstdc++.so.6(CXXABI_1.3)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libpthread.so.0(GLIBC_2.3.2)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libpthread.so.0(GLIBC_2.2.5)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libnuma.so.1(libnuma_1.2)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libnuma.so.1(libnuma_1.1)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libm.so.6(GLIBC_2.2.5)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libgcc_s.so.1(GCC_3.3.1)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libgcc_s.so.1(GCC_3.0)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libdl.so.2(GLIBC_2.2.5)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libcrypt.so.1(GLIBC_2.2.5)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libaio.so.1(LIBAIO_0.4)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libaio.so.1(LIBAIO_0.1)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: grep for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: coreutils for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: /usr/bin/perl for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: /bin/sh for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: /bin/sh for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: /bin/bash for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libstdc++.so.6()(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libpthread.so.0()(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libnuma.so.1()(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libm.so.6()(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libgcc_s.so.1()(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libdl.so.2()(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libcrypt.so.1()(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libaio.so.1()(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Running transaction check
---> Package mysql-community-client.x86_64 0:5.6.42-2.el7 will be installed
--> Processing Dependency: mysql-community-libs(x86-64) >= 5.6.10 for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: rtld(GNU_HASH) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(Sys::Hostname) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(IPC::Open3) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(Getopt::Long) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(File::Temp) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(Fcntl) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(Exporter) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4)(64bit) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: libstdc++.so.6(CXXABI_1.3)(64bit) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: libpthread.so.0(GLIBC_2.3.2)(64bit) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: libpthread.so.0(GLIBC_2.2.5)(64bit) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: libm.so.6(GLIBC_2.2.5)(64bit) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: libgcc_s.so.1(GCC_3.0)(64bit) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: libdl.so.2(GLIBC_2.2.5)(64bit) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: /usr/bin/perl for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: /bin/sh for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: libtinfo.so.5()(64bit) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: libstdc++.so.6()(64bit) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: libpthread.so.0()(64bit) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: libncurses.so.5()(64bit) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: libm.so.6()(64bit) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: libgcc_s.so.1()(64bit) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: libdl.so.2()(64bit) for package: mysql-community-client-5.6.42-2.el7.x86_64
---> Package mysql-community-common.x86_64 0:5.6.42-2.el7 will be installed
---> Package mysql-community-server.x86_64 0:5.6.42-2.el7 will be installed
--> Processing Dependency: systemd for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: systemd for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: shadow-utils for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: rtld(GNU_HASH) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: procps for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(warnings) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(strict) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(if) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(Sys::Hostname) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(POSIX) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(Getopt::Long) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(File::Temp) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(File::Spec) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(File::Path) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(File::Copy) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(File::Basename) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(Fcntl) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(Data::Dumper) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(DBI) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: net-tools for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.9)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.11)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libstdc++.so.6(CXXABI_1.3)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libpthread.so.0(GLIBC_2.3.2)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libpthread.so.0(GLIBC_2.2.5)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libnuma.so.1(libnuma_1.2)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libnuma.so.1(libnuma_1.1)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libm.so.6(GLIBC_2.2.5)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libgcc_s.so.1(GCC_3.3.1)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libgcc_s.so.1(GCC_3.0)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libdl.so.2(GLIBC_2.2.5)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libcrypt.so.1(GLIBC_2.2.5)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libaio.so.1(LIBAIO_0.4)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libaio.so.1(LIBAIO_0.1)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: grep for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: coreutils for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: /usr/bin/perl for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: /bin/sh for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: /bin/sh for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: /bin/bash for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libstdc++.so.6()(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libpthread.so.0()(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libnuma.so.1()(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libm.so.6()(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libgcc_s.so.1()(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libdl.so.2()(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libcrypt.so.1()(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libaio.so.1()(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Running transaction check
---> Package mysql-community-client.x86_64 0:5.6.42-2.el7 will be installed
--> Processing Dependency: rtld(GNU_HASH) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(Sys::Hostname) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(IPC::Open3) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(Getopt::Long) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(File::Temp) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(Fcntl) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(Exporter) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4)(64bit) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: libstdc++.so.6(CXXABI_1.3)(64bit) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: libpthread.so.0(GLIBC_2.3.2)(64bit) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: libpthread.so.0(GLIBC_2.2.5)(64bit) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: libm.so.6(GLIBC_2.2.5)(64bit) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: libgcc_s.so.1(GCC_3.0)(64bit) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: libdl.so.2(GLIBC_2.2.5)(64bit) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: /usr/bin/perl for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: /bin/sh for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: libtinfo.so.5()(64bit) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: libstdc++.so.6()(64bit) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: libpthread.so.0()(64bit) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: libncurses.so.5()(64bit) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: libm.so.6()(64bit) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: libgcc_s.so.1()(64bit) for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: libdl.so.2()(64bit) for package: mysql-community-client-5.6.42-2.el7.x86_64
---> Package mysql-community-libs.x86_64 0:5.6.42-2.el7 will be installed
--> Processing Dependency: rtld(GNU_HASH) for package: mysql-community-libs-5.6.42-2.el7.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4)(64bit) for package: mysql-community-libs-5.6.42-2.el7.x86_64
--> Processing Dependency: libstdc++.so.6(CXXABI_1.3)(64bit) for package: mysql-community-libs-5.6.42-2.el7.x86_64
--> Processing Dependency: libpthread.so.0(GLIBC_2.3.2)(64bit) for package: mysql-community-libs-5.6.42-2.el7.x86_64
--> Processing Dependency: libpthread.so.0(GLIBC_2.2.5)(64bit) for package: mysql-community-libs-5.6.42-2.el7.x86_64
--> Processing Dependency: libm.so.6(GLIBC_2.2.5)(64bit) for package: mysql-community-libs-5.6.42-2.el7.x86_64
--> Processing Dependency: libgcc_s.so.1(GCC_3.0)(64bit) for package: mysql-community-libs-5.6.42-2.el7.x86_64
--> Processing Dependency: libdl.so.2(GLIBC_2.2.5)(64bit) for package: mysql-community-libs-5.6.42-2.el7.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: mysql-community-libs-5.6.42-2.el7.x86_64
--> Processing Dependency: /sbin/ldconfig for package: mysql-community-libs-5.6.42-2.el7.x86_64
--> Processing Dependency: /sbin/ldconfig for package: mysql-community-libs-5.6.42-2.el7.x86_64
--> Processing Dependency: libstdc++.so.6()(64bit) for package: mysql-community-libs-5.6.42-2.el7.x86_64
--> Processing Dependency: libpthread.so.0()(64bit) for package: mysql-community-libs-5.6.42-2.el7.x86_64
--> Processing Dependency: libm.so.6()(64bit) for package: mysql-community-libs-5.6.42-2.el7.x86_64
--> Processing Dependency: libgcc_s.so.1()(64bit) for package: mysql-community-libs-5.6.42-2.el7.x86_64
--> Processing Dependency: libdl.so.2()(64bit) for package: mysql-community-libs-5.6.42-2.el7.x86_64
---> Package mysql-community-server.x86_64 0:5.6.42-2.el7 will be installed
--> Processing Dependency: systemd for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: systemd for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: shadow-utils for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: rtld(GNU_HASH) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: procps for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(warnings) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(strict) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(if) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(Sys::Hostname) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(POSIX) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(Getopt::Long) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(File::Temp) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(File::Spec) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(File::Path) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(File::Copy) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(File::Basename) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(Fcntl) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(Data::Dumper) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: perl(DBI) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: net-tools for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.9)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.11)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libstdc++.so.6(CXXABI_1.3)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libpthread.so.0(GLIBC_2.3.2)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libpthread.so.0(GLIBC_2.2.5)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libnuma.so.1(libnuma_1.2)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libnuma.so.1(libnuma_1.1)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libm.so.6(GLIBC_2.2.5)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libgcc_s.so.1(GCC_3.3.1)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libgcc_s.so.1(GCC_3.0)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libdl.so.2(GLIBC_2.2.5)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libcrypt.so.1(GLIBC_2.2.5)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libaio.so.1(LIBAIO_0.4)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libaio.so.1(LIBAIO_0.1)(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: grep for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: coreutils for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: /usr/bin/perl for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: /bin/sh for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: /bin/sh for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: /bin/bash for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libstdc++.so.6()(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libpthread.so.0()(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libnuma.so.1()(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libm.so.6()(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libgcc_s.so.1()(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libdl.so.2()(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libcrypt.so.1()(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: libaio.so.1()(64bit) for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: /sbin/ldconfig for package: mysql-community-libs-5.6.42-2.el7.x86_64
--> Processing Dependency: /sbin/ldconfig for package: mysql-community-libs-5.6.42-2.el7.x86_64
--> Processing Dependency: /bin/bash for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: /usr/bin/perl for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: /usr/bin/perl for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: /bin/sh for package: mysql-community-client-5.6.42-2.el7.x86_64
--> Processing Dependency: /bin/sh for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Processing Dependency: /bin/sh for package: mysql-community-server-5.6.42-2.el7.x86_64
--> Finished Dependency Resolution
Error: Package: mysql-community-client-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libm.so.6(GLIBC_2.2.5)(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libstdc++.so.6(GLIBCXX_3.4.15)(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libpthread.so.0(GLIBC_2.3.2)(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libgcc_s.so.1(GCC_3.0)(64bit)

Error: Package: mysql-community-client-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libstdc++.so.6(GLIBCXX_3.4)(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: perl(File::Copy)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libpthread.so.0()(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libcrypt.so.1(GLIBC_2.2.5)(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libnuma.so.1()(64bit)

Error: Package: mysql-community-client-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libpthread.so.0(GLIBC_2.2.5)(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: perl(DBI)

Error: Package: mysql-community-client-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libgcc_s.so.1()(64bit)

Error: Package: mysql-community-client-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: perl(Sys::Hostname)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libstdc++.so.6(GLIBCXX_3.4.9)(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: /bin/sh

Error: Package: mysql-community-client-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libstdc++.so.6(CXXABI_1.3)(64bit)

Error: Package: mysql-community-client-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libncurses.so.5()(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libgcc_s.so.1(GCC_3.3.1)(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libnuma.so.1(libnuma_1.2)(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libstdc++.so.6(GLIBCXX_3.4)(64bit)

Error: Package: mysql-community-client-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: /bin/sh

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: perl(strict)

Error: Package: mysql-community-client-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: perl(Exporter)

Error: Package: mysql-community-client-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: /usr/bin/perl

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: perl(File::Spec)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: coreutils

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: rtld(GNU_HASH)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libaio.so.1(LIBAIO_0.1)(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libdl.so.2()(64bit)

Error: Package: mysql-community-libs-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libdl.so.2()(64bit)

Error: Package: mysql-community-libs-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libm.so.6(GLIBC_2.2.5)(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libdl.so.2(GLIBC_2.2.5)(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: perl(File::Temp)

Error: Package: mysql-community-client-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: perl(File::Temp)

Error: Package: mysql-community-client-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: perl(IPC::Open3)

Error: Package: mysql-community-libs-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libm.so.6()(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libm.so.6()(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: perl(Fcntl)

Error: Package: mysql-community-client-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libc.so.6(GLIBC_2.17)(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libstdc++.so.6(CXXABI_1.3)(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libaio.so.1()(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: perl(File::Basename)

Error: Package: mysql-community-libs-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libstdc++.so.6(GLIBCXX_3.4)(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: procps

Error: Package: mysql-community-libs-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: /sbin/ldconfig

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: /bin/bash

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libstdc++.so.6()(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: perl(File::Path)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libstdc++.so.6(GLIBCXX_3.4.11)(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: perl(if)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libm.so.6(GLIBC_2.2.5)(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: perl(Data::Dumper)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libc.so.6(GLIBC_2.17)(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: net-tools

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: perl(POSIX)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libnuma.so.1(libnuma_1.1)(64bit)

Error: Package: mysql-community-client-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libpthread.so.0()(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libpthread.so.0(GLIBC_2.2.5)(64bit)

Error: Package: mysql-community-client-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libstdc++.so.6()(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libgcc_s.so.1()(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: perl(Sys::Hostname)

Error: Package: mysql-community-libs-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libgcc_s.so.1(GCC_3.0)(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: shadow-utils

Error: Package: mysql-community-client-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libtinfo.so.5()(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: perl(warnings)

Error: Package: mysql-community-libs-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libdl.so.2(GLIBC_2.2.5)(64bit)

Error: Package: mysql-community-libs-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libpthread.so.0(GLIBC_2.2.5)(64bit)

Error: Package: mysql-community-client-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libdl.so.2()(64bit)

Error: Package: mysql-community-libs-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: rtld(GNU_HASH)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libcrypt.so.1()(64bit)

Error: Package: mysql-community-libs-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libpthread.so.0()(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: /usr/bin/perl

Error: Package: mysql-community-client-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: perl(Fcntl)

Error: Package: mysql-community-client-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libm.so.6()(64bit)

Error: Package: mysql-community-client-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libpthread.so.0(GLIBC_2.3.2)(64bit)

Error: Package: mysql-community-libs-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libstdc++.so.6()(64bit)

Error: Package: mysql-community-client-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libgcc_s.so.1(GCC_3.0)(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: grep

Error: Package: mysql-community-libs-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libgcc_s.so.1()(64bit)

Error: Package: mysql-community-client-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: rtld(GNU_HASH)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: systemd

Error: Package: mysql-community-libs-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libpthread.so.0(GLIBC_2.3.2)(64bit)

Error: Package: mysql-community-client-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libdl.so.2(GLIBC_2.2.5)(64bit)

Error: Package: mysql-community-libs-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libc.so.6(GLIBC_2.17)(64bit)

Error: Package: mysql-community-libs-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libstdc++.so.6(CXXABI_1.3)(64bit)

Error: Package: mysql-community-client-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: perl(Getopt::Long)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: libaio.so.1(LIBAIO_0.4)(64bit)

Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community)

       Requires: perl(Getopt::Long)

You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
上面是报错内容
需要更改/etc/yum.repos.d/mysql-community.repo
/etc/yum.repos.d/mysql-community-source.repo
文件配置吗,尝试更改enabled还是无法实现

分享到
取消 提交回答
全部回答(1)
  • juanmao
    2019-07-17 23:23:52

    依赖的包没有装

    0 0